Cannot get "TT-Premium C-2300" TV-Card to run with Kubuntu

I recently found an old TT-Premium TV-Card and wanted to use it again with my Kubuntu.
The target machine is an (rather old) Core2Duo with 4 GB.
It behaved fine with the installation of Kubuntu 19.04.
The card is obviously recognized with Kubuntu (see screenshot).
I downloaded the firmware for it from here and placed it, where it has to be (see screenshot).

As stated here, the card should be working fine with Linux.
I remember to have had the card up and running some time ago, but that was an older Distro, Mint 18 or so…

First I tried with VLC, but no success.
Then I installed Kaffeeine, but there too, no TV. Kaffeeine recognizes the device “video0” though…

It’s not that of an urge, I just thought it would be nice to (re-)use this piece of hardware for watching TV in my closet, but if someone has a helpful hint, I would like to hear (and test) it.
Fast Edi

Does DVB-C still work, in general?

Yep. I run three normal tv sets connected to the same line.
It works.
They stopped DVB-T, when I remember correctly.

They discontinued DVB-T, which was superseded by DVB-T2. There is also DVB-C2, so I saw the possibility of DVB-C being also discontinued. Well, at least you have proof that it still works.

1 Like

But as I stated, I used this card a while ago and it worked OK.
Maybe I get to test it with another system in the next weeks.