Device Communication Problems with HP Printer on Ubuntu 20.04

that’s understandable. i will wait to see if you do so before trying to help troubleshoot further.

1 Like

one quick way to see (approximately) if that will help without having to reinstall and possibly end up back in the same spot, would be to create a liive usb (or dvd) and see if you can print from there.

1 Like

well, if you have any further suggestions… Point is: I need to go on, and either buy another printer or re install… Using it for my business…,

there are plenty of other options to look at and commands to run, but there is no way to guarantee a satisfactory outcome and it can take some time trying to get there. if you need to move forward with another printer, that makes sense.

one quick command is lpinfo -v though it may return the same results as localhost.

these were the next few things on my list after that:

  1. try hp-check -i again in case the error is different without a print job in the queue
  2. after that see if previous version of hplip was uninstalled/purged or just installed over the top of it since that might leave configuration files which still prevent printing
  3. recommend this link for dealing with those regarding the sudo rm -rf section at the bottom:
  4. check to see if there are any obvious errors or problems in printers.conf (located in /etc/cups - probably easiest to cat /etc/cups/printers.conf. note: your actual conf file may differ in name but should be in /etc/cups. also note: you may need to use sudo to cat that file)

The problem is solved. I uninstalled hplip using this guide:

and rebooted. After that the printer and scanner simply work.



The OS can become easily confused, if duplicate drivers are found for a single device.


thanks. it worked as i was so worried since i need the printer for my online classes.

1 Like