Faulty Update Prompts

For the past several weeks, I’ve been getting faulty update prompts that I don’t recognize. I can click any of the buttons, and it goes away but nothing happens.

Screenshot below:

I assume it’s related to n app I installed, possibly Brave Browser Beta, which I removed again. I’d like to know either what this is good for, or how to get rid of it.


1 Like

Those look like normal notifications from the update-notifier, to me. If clicking the buttons doesn’t have any effect, maybe you have update-notifier installed without update-manager? I believe that’s what update-notifier launches to display/apply pending updates. (update-notifier and update-manager are both separate apt packages.)

1 Like

Thanks. I checked: both update-notifier and update-manager are installed. When I run update-manager from the CLI, it calls the normal GUI software updater. As this prompt is new, is this part of Ubuntu 20.xx? I upgraded from 16 a few months ago, though, off the top of my head, I’d say, these prompts are newer than that. Also, the software updater still runs separately, at its own intervals. Can the update-notifier be turned off, or can I just remove it without harming anything?

1 Like

Which command did u run??

I ran update-manager

1 Like

Then why don’t u use the terminal way to upgrade ur system every time?
To do that,
U have to run:
sudo apt update && sudo apt upgrade

You seem to miss my question; I know how to keep my system current.

The question is: what is this annoying prompt, and how do I get rid of it?


I’m just wondering if Brave Browser Beta left stuff behind? I don’t know if Nautilus has a search function, as I use Nemo? Ctrl+F in Nautilus and type Brave if there is a search box? If it finds anything to do with Brave, ignore the icon files that obviously come up, but anything else delete. I assume you ran sudo apt update, sudo apt upgrade?? Usually if it finds anything that is obsolete or it does not need any more, it lists what is not needed and prompts the command sudo apt autoremove, to remove them. Another way is to install Synaptic package manager and search for anything to do with Brave. I take it, that it was a Deb install? Though thinking back to how Brave Browser gets installed, if it was from a PPA then Synaptic will still pick up on it, if you did not delete the PPA? Usually files that are left behind from an app are in hidden files in .config, in your home folder. So as you do not need root privileges for that, should be safe enough to delete anything to do with Brave. I’ve never seen that signage from Update Manager before, as I use Linux Mint 20.04.1 XFCE with Nemo file manager instead of Thunar. Sorry I can’t be of more help.

1 Like