Finally NVidia open source - but too late for me

Well, AMD is supposed to me compatible in general, as they are more open to the FOSS world. Whereas NVIDIA is supposed to as proprietary as possible. I don’t know the details, though. I just want this stuff to work. That’s it. I don’t want to have to deal with such basics, at all.

2 Likes

Use Waterfox instead. It downloads as an old fashioned archive and you just install the binary somewhere outside the package system . They notify you of updates. It looks just like firefox, without the crap.

Agree on snap… avoid at all cost

2 Likes

They’ve broken the NVIDIA driver somewhere along the line for Linux. I’ve gone back to Xubuntu 20.04, as that is using 18.04 XFCE Environment, at least it is from the Ubuntu mini ISO I used. Installed the minimal installation of Xubuntu, though got that annoying Nouveau warning. Updated to 470 NVIDIA Drivers and touch wood and whistle everything running smoothly.

there’s two things that really REALLY shit me about Gnome…

  1. every revision breaks the dock extensions, so there’s a plethora of distro specific dash to dock extensions, some work on all distros… I was using one called “floating dock” on Ubuntu 20 and Fedora 35, it was working… Upgraded Fedora 35 to 36 - “Floating Dock” stops working (incompatible)… Can’t remember what I used to replace that… I think it’s the Dash to Dock for COSMIC (which came from PopOS I believe).
  2. snap centric distros, like Ubuntu - really F–K with users, 'cause firefox AND chromium are snapshots in Ubuntu, the “chrome gnome extension”, that lets you find and install extensions from extensions.gnome.org using either firefox or chromium is BROKEN… I discovered that on my RPi4 running Ubuntu 22.04… On x86_64 this isn’t a problem, 'cause I can run Google Chrome and/or Brave, but neither of those are available for arm64 Linux…

There’s a thing you can install to resolve that, “Extension Manager”, and it can find extensions from extensions.gnome.org. But does that work in f–king Fedora? NOPE! You have to get it from a f–king FLATPAK! SHEESH! More bloated stuff like snap/appimage! what else is there… and guess what?

Fedora disable installing flatpaks from flathub anyway… So it’s a messy convoluted process of

flatpak remote-modify --enable flathub
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install flathub com.mattjakeman.ExtensionManager

That thing above TAKES FOREVER!!! CHEEZUS!!! Gets about 300 gigs of bloatware from somewhere that’s not very close by!

flatpak run com.mattjakeman.ExtensionManager

It’s like a bad joke, a comedy of errors, just when things seem to be settling down, quiescing, the major desktop Linux vendors go and chuck a jerry can of gasoline on it!!!

Aaaarrrgggghhhhh!

And - in Gnome 42, the libadwaita theme blocks a whole bunch of theming from working, e.g. window control widgets in some dialogs insist on using Adwaita, even though you installed some other theme with its own window control widgets - libadwaita was to be BIG BROTHER… I think I’ll try and stick with Gnome 41 for a while longer on this desktop machine, running Fedora 35…


And no, mate / mint / cinnamon or whatever are not the answers… nor is KDE…
I may infact revert back to Ubuntu 20.04 which at least still have a few more years up its sleeve…

There is another solution. Use Waterfox in place of firefox. It is almost identical to firefox. It comes as an old fashioned archive download. You just install the binary where you want it, eg in home directory.
, and put in some libraries.
I use it in x86-64, but it has what it calls MacOS -ARM

1 Like

That’s how I run firefox ESR on some of my x86_64 kit - I have a firefox binary folder in ~/sbin/ and a *.desktop file pointing at that (same with TOR).

But - there’s no Firefox ESR or Waterfox as a standalone binary compiled for arm64 Linux (Waterfox dos have an arm64 binary for MacOS / Apple M1). The problem I encountered on Gnome 42 on Ubuntu 22.04, was on my RPi4, running arm64 Linux…

Yeah, that is a different ARM.
I thought apps were supposed to be architecture independent? Most of them are just C code, and that is portable. I guess complex things like browsers break the rules? … or is it that they just have to compile it for each architecture?

There’s always stuff that doesn’t work, even with ALL the source code…

e.g. I tried, and tried, and tried again, to compile the Sayonara Media player to run on armhf… ended up giving - then I found some post somewhere, that someone had tried to build it from source, for i386 - and hit the same issues - and the author replied that it’s got hard references to some 64 bit stuff… Note my first attempt, on armhf, was actually running on a 64 bit capable RPi4… Later on running aarch64/arm64 Raspbian, I was able to compile it (it took HOURS! with maybe two hours just assembling all the correct libraries and dependancies)…

Another “recent” case, in 2020 (man that seems like an eternity agol!) - I tried to get POVRay raytracer compiled for Sparc on Solaris 10… Meh! That was like THREE DAYS and maybe a total all up 10-16 hours or so, of wasted effort… I NEVER ever got there! So many libraries and dependancies… The source tree I grabbed is actually called “UNIX”, but it was about 75% LINUX centric. In 1992, I got POVRay for DOS on a Floppy Disk, and showed some colleagues what you could do, and we got the C source code off Compuserve, and compiled it for Motorola 88010 RISC running DG-UX on DG AViiON system…

Once upon a time, one might have been able to grab binaries of POVRay for Solaris, but Oracle (what a bastard of a company) sent a cease and desist letter to the maintainers of sunfreeware.org… I found binaries for Solaris 8 in some archive, but they wouldn’t run on Solaris 10, missing some libraries or something, not even in a “branded zone” of Solaris 8 as a container on Solaris 10…

If it doesn’t run a 64-bit operating system, then the whole 64-bitness gets “lost”. That’s why it worked the second time on arm64.

That’s very common, unfortunately.

It’s so common, I actually wrote a tool making it less a pain.

I just noticed, I haven’t provided binaries, yet. Will do that, eventually.

Dependency hell…

Yes, I don’t understand why so many always talk about “UNIX”. I usually talk about Linux specifically, because “UNIX” (or some even say *NIX, which sounds even broader…) is so broad, it’s very hard to account for all flavours, except you are seriously strict about designing according to POSIX…

@daniel.m.tripp ,
Yes I tried recently with LibreWolf.
Downloaded source from Github and followed their build instructions exactly. Compiling kept failing with not being able to find include files, I gave up after wasting several days, went to Waterfox instead.

I used to do lots of ‘porting’ on FreeBSD. It seems to have got more complicated today.