Firefox update failed

There is a new release of Firefox version 66.04.
I like to update version 66.03. (there are problems with add-ons)
So I download the new version 66.04 and tryed to install the new one, but I did not succeed.
I followed several installation options:
https://linuxconfig.org/how-to-install-uninstall-and-update-firefox-on-ubuntu-18-04-bionic-beaver-linux#h6-2-2-update-firefox

When I reboot I have still version 66.03
It seems that I don’t no how to install or upgrade Firefox.
How do I get a working versions of 66.04 ?

1 Like

I couldn’t get it to install either. I downloaded firefox-66.0.4.tar.bz2 and after the unpacking, I got this error when trying to run Firefox:
Unable to open /var/lib/flatpak/exports/share/dconf/profile/user: Permission denied
I found this link if it helps any of you - it’s over my head.

I had trouble with the add-ons/extensions in Firefox and was able to fix it (work around) with ‘about:config’ and changing ‘xpinstall.signatures.required’ to FALSE.
Jim
Linux Mint 19.1

1 Like

It is usually best to wait until the updates appear in update manager, before installing them. I know we all want the latest version, but sometimes, it is best to remember; if it ain’t broke don’t fix it ! The suggestion by @panhead51 will work if you do it to fix your current problem.

4 Likes

I have no problems with flatpak or errors about it, I only want to know/learn: how to manually update FF.
I can remove the current version but I don’t know if the current settings (profile) will be saved.

1 Like

do you have a firefox account?

what distro are you using? where did you download from and what did you try exactly? that link has multiple options from a plain sudo apt install to installing from a ppa.

I have just seen that Firefox has been updated again to 66.05
Update: To get the update now, select “Help” from the Firefox menu, then pick “About Firefox.” Mac users need to select “About Firefox” from the Firefox menu. If you do not use the English language version, Fully Localised Versions are available for download.
This is from my friend Corrine who is a long standing member of the Security Industry and who sends out notifications as soon as they happen.

1 Like

did you install the flatpak version or did you get yours straight from the mozilla website?

1 Like

I don’t use flapak, I hardly don’t know what that is.

1 Like

I have seen that update. It’s a tar file and I can unpack it and then I don’t know what to do with it.
Xubuntu 18.04.2

2 Likes

I downloaded from the Firefox site.
(When I hit ‘Help’ and ‘About Firefox’, there is nothing there about updating the version.)
I only tried the upgrade because I have a friend using Windoze and he is having trouble with add-ons/extensions and the ‘about:config’ change did not work on his PC. I thought I’d see if I could get the new version on mine before trying it on his PC.

1 Like

I went to the Mozilla site and downloaded firefox-66.0.4.tar.bz2.
I used ‘bzip2 -dk firefox-66.0.4.tar.bz2’ on a command line to unpack it from the Downloads folder.
It created the file: firefox-66.0.4.tar
I used ‘tar -xvf firefox-66.0.4.tar’ on a command line to unpack that.
This created a ‘firefox’ folder in my Downloads folder.
Inside that is a firefox which I executed from the command line. It’s still 66.03.
(I also don’t use flatpak)

1 Like

I found the solution for manual installation here:

https://linuxconfig.org/how-to-install-uninstall-and-update-firefox-on-ubuntu-18-04-bionic-beaver-linux

From this point:

Install and Update Firefox with Direct download To: all Done.

Change the language settings in FF to your own language and you are done.

Firefox 66.05 is properly running :slight_smile:

4 Likes

That worked for me Pollewops. THANKS!
Thanks to all for your help!
Jim

1 Like

I’m trying to update Firefox from the update manager and getting an error message.
Should I just wait and check back every so often. I don’t think the problem is at my end.
Here’s the error message I am getting.
W: Failed to fetch http://packages.linuxmint.com/pool/upstream/f/firefox/firefox_66.0.3+linuxmint1+tessa_amd64.deb
404 Not Found [IP: 68.235.39.11 80]

For some reason my Firefox is at 66.0.2.

i found the answer below that may help. firefox in ubuntu is currently at 67.0 so i’m not sure why your update manager would be looking for 66.0.3.

https://forums.linuxmint.com/viewtopic.php?t=216880

2 Likes

Wow, that did the trick. I remember setting the software manager to perform an auto refresh every so often. Maybe that option is not working, or I got it set wrong, or don’t understand the setting.
Anyway, not only did Firefox update correctly, but with the refresh, I got a lot more updates.
Thanks!

1 Like

i logged into my mint partition to look and make sure i was giving you good advice. i had trouble with one of the repo mirrors not connecting and giving me a 503 error. there are a lot of settings to keep in mind :slight_smile: i’m glad that got you sorted.

1 Like

There has been a recent problem with Firefox updates although this has not been in Mint (mostly Windows). The easiest way to clear update problems in Mint is to simply use the refresh and that will most times clear things. Failing that simply restart and that will do it. Alternatively, just disconnect your router for about 10 seconds and that will refresh the connection, then reconnect and then the problems are cleared as it is not still chasing the routes. It is advisable to do this once in a while anyway.

2 Likes