Fossbytes deals email links not working

For the last few weeks, my emails from FossBytes deals have links that error out. I was trying to buy a VPN, but when I click on the link, I get this message:
It looks like the link pointing here was faulty. Maybe try searching?
I tried contacting FossBytes through the “Contact Us” on their page, but they never got back to me.
Anyone else having this issue? It happens to me no matter what browser, computer or device I use.

1 Like

Could you provide screenshots of what is happening?

Did you try to open the links in a different place, like, for example, at your friend’s home?

I have tried it from multiple devices, plus, emailed it to a couple of different people, and all with the same results. Here is a screenshot when I / they click on any links in the email.

If that is the case, the fault should be with FossBytes. They will respond to your request sooner or later, as they are probably very interested in their ad links being actually able to work.

Thanks for responding. Hopefully, they will answer me. It’s been a while since I sent them a message. Here is one of the links if you want to try it to see what you get.

Does indeed not work. They would need to take care of that.

1 Like