How do I reformat a USB stick containing read-only files?

did you ever try

and/or something like smartmontools to try and make sure that the disk itself is sound?


Hi. Yes, I have just tried the ‘badblocks’ method and got the following message: Checking blocks 0 to 7711
Checking for bad blocks (read-only test): 0.00% done, 0.00 elapsed. (0/0/0 errors)
Pass completed, 0 bad blocks found. (0/0/0 errors)

Do you think it actually checked the USB drive since it gave 0.00% done?
As to the smartmontools, I have not tried. I clicked on the link and had a look around but my Linux experience at present does not extend to that. Thanks for getting back, it’s taking a while.

1 Like

Your device is probably broken.

There was a discussion about a very similar situation. You should read that one, as it explains a lot of possible reasons for the symptoms you experience.

Oh dear. Could you roughly point me in the general direction the discussion was held please so I can read it? Thanks

There is a search button in the top bar.

Thanks. I think I have found what you were referring to.

@sheli I am interested in this subject. I would like to suggest three methods which you may tryif you and have not tried already:

  1. click on Disks in main menu. find you USB and click on it . in the right side you will fin wheel s (3rd item) click on it and you will find a list of Menus relating to the disk. You may try all one by one or any selected by you.

  2. in your terminal issue lsblk to find out your drive and the issue the following command
    sudo dd if=/dev/zero of=/dev/yourdrive

  3. in your terminal issue the following commands
    sudo add-apt-repository ppa:mkusb/ppa # and press Enter
    sudo apt-get update
    sudo apt-get install mkusb
    you will get a prompt click “YES”
    Now “mkusb” will ask you if you wish to proceed with the formatting of the data, ‘Stop’ will be selected by default. You now select ‘Go’ and click ‘OK’.
    The window will close and your terminal will look like this.

    In a few seconds, the process will be completed and you will get a window popup saying "IMAGE NOT FOUND
    Please remove the disk and reinsert again to see whether it is formatted.
    Hope one of the method will work for you.:slightly_smiling_face:

@Sheli SorryI forgot the most important one. It is “Testdisk” This used by forensic. You will have to install it by
sudo apt install testdisk
and after installation in terminal issue: $ testdisk
you may find about it in :

These suggestions probably won’t work, because the original poster already tried similar methods and it did not work out. I am quite sure there is something wrong with the hardware.

@Akito : yes You are right. There might be something wrong with the hardware.