How I solved it _ Sharing the "Aha" moment

Everyone comes through some sort of problems when using Linux and finally overcomes it. Result is that we get to know the real root of the problem and when we find the solution, we really feel great – Like we have unravelled some great mystery. I want you to share your own part of problems and what was the clue or thing that you got to learn, and what was the aha moment, as replies to this thread, in brief.

I guess everyone would like reading, just as some mysterious story.

There is no demarcation of topics regarding which distro you use or any feature, you can share anything as long as its something about Linux problems and solutions.

Reading this thread in my opinion would increase the knowledge of readers in random direction, and help them in increase the breadth of their open source knowledge, resulting in serendipitous moments.

I hope you all would like sharing and reading, and most importantly HAVE FUN.

I have Nvidia graphics card, and I’m using Linux Mint. Nouveau display drivers were installed as default, which are open source display drivers for the nvidia card. I thought of once experimenting with the proprietry drivers provided by nvidia. Nvidia drivers had three options to choose,

  1. Power saving mode (only integrated graphics use)
  2. Nvidia on demand
  3. Nvidia performance mode

I was on Power saving mode, so I changed it to Nvidia on demand mode, just for experimentation. It said I’d have to log out and back log in to have changed take effect. Instead I rebooted the system. But after that, my computer screen was blank after boot. When I pressed ctrl + F1 it showed that it was trying to log in with my username, but it was stuck at the same screen. I started googling to find solutions, some said to purge nvidia graphics, with the version name. But I didn’t know the current version of the nvidia driver installed, I tried to know it with some command but I was not able to scroll the terminal page (I was using the root mode option of the recovery mode option from the grub menu). Please tell me if you know how to scroll the terminal there.

Then I thought I should change the Nvidia prime profile back to power saving mode, then it may work. I googled for the command and ran “sudo prime-select intel”, and then I rebooted. And it worked, that was my ‘aha’ moment.

I realized that the problem arose because I rebooted the system instead of just logging out and logging back in. Next time I tried to change to Nvidia on demand, it worked fine.

Finally My review of Nouveau vs Nvidia driver : I don’t know about many technical stuffs, but as a beginner linux user I can say that Nouveau was giving me much better battery backup than even the power saving mode of the Nvidia driver. So I switched back to Nouveau.

I have a dual boot, and I get more battery backup on linux than Windows 11. I guess that is happening because the cultprit may again be the Nvidia driver used on windows, I don’t know, Its just a guess.

You’re talking two different techs here…

Your machine has a discrete GPU and an Intel APU (intel graphics) “integrated GPU” chipset… Prime software is used to switch between one or other, and yeah, since forever, the way to activate one or the other, is log out and log in again. Note : I had something similar with an Asus ROG laptop - if I wantd to change I had to :

  1. run prime, set which GPU I wanted
  2. logout

I don’t see how rebooting could, or can break anything, that certainly didn’t happen in my experience…

If you want to take advantage of all the NVidia features, e.g. for gaming (which was my case) you’ll most likely need the Propietary NVidia driver stack, and they worked well with Prime.

The main reason for switchable graphics mode, was battery usage. I mostly used my ROG powered to the mains, so nearly ALWAYS ran the NVidia proprietary drivers all the time…

1 Like

Yeah, I’m also surprised how rebooting can break anything, but it happened. I was not able to boot my computer after that, until I switched back to Prime Power saving mode from the terminal of the recovery mode. But when I again switched back to prime and then log out and logged in again (as suggested), it worked fine.

If you’re interested you can try rebooting at that point (instead of log out and logging in back), see what happens.

Not that interested - mainly 'cause there’s little point - I sold that Asus ROG laptop over 5 years ago… I don’t have any other devices with “Shared Graphics”…

1 Like