How to Create a (persitent) Bootable Windows 10 USB in Linux

I also found this web page when I search on google. It is on It’s Foss.

It’s the tutorial I’m trying to implement…

I was trying to say that the iso is suppose to be written to a USB flash drive. In your post of gparted

it show a 1.0 TB Hard Disk. That is not a USB flash drive. I am not sure you can write the WTG file to an external hard disk (and have it be able to boot) even tho it is connected to the your PC via the USB port.

Reading the post, it said “Since the ISO and its content are more than 4 GB in size, I recommend a USB of at least 8 GB in size.” I believe the author “assumes” the USB is a USB Flash drive.

Maybe @Akito or @nevj can answer if this is right or wrong.

Are you in the directory where the .iso file is?
Otherwise you have to give the full pathname

I think you can write a .iso file to any block device, and it will be bootable as long as it is a hybrid .iso

It concerns me that @HadaDeLaLuna is showing us an external 1Tb HDD. I hope he has not got his device names mixed up and written the .iso to an HDD instead of to a flash drive?

I told him to use lsblk to check, before he did the dd copy.

Note added later.
I notice that @HadaDeLaLuna has stated

I need a persistent MS Windows on an external USB disk.

So he did intend to write on an external USB , not a flash drive
So @easyt50 I take all that back… that part of it is OK.
Only problem is it will not be bootable , if your test is correct.
He needs to do the isohybrid filename.iso conversion, then repeat the dd step. Then the external USB should boot

Output of the file command for the Win 10 d/l.

easyt@7040:~/Downloads$ file Win10_21H2_English_x64.iso
Win10_21H2_English_x64.iso: ISO 9660 CD-ROM filesystem data ‘CCCOMA_X64FRE_EN-US_DV9’ (bootable)

I believe this means the file is not a hybird iso.

So what you need to do is convert it to hybrid
isohybrid filename.iso
It converts the file, does not make a new file
So you should only do it once
Hence use the file statement to check first


So @HadaDeLaLuna needs to use a Flash drive or convert his Win 10 file to a hybird iso file.

He just needs to use isohybrid to convert the .iso file to hybrid, then redo the dd step.
See Note added
on my previous message

But , I want to see the result of him doing the file filename.iso check first. His file may be different from yours. Someone may have already converted it. You cant tell by the name.
I think his file check failed becaise he did not go to the directory where the .iso file was. We have tomget him to try again.

I am happy now that he intended to dd it to an external HDD… We missed that bit in his first post.

1 Like

Hi @nevj,
I still believe he needs a flash drive. The file that was d/l’ed is a Win 10 install iso, if he got from the same guide on ‘It’s Foss’ that I got my file from. Once he creates a bootable flash drive, then he boots it and runs the install process of Win 10 to a USB attach HDD.

You know more than me. I have little experience with Windows

If it was a Linux.iso

  • it would most likely already be hybrid
  • so you could just copy it to any block decice, and it would boot

But I have to admit, Windows may be different.

Does this mean the internet reference he followed is wrong?

We need to sort this out and get him some advice that is reliable.

I D/L’ed the file and followed the ‘It’s Foss’ guide and my flash drive would not boot. I try writing the file using Mint’s drop down window ‘Create Bootable USB’ and again I got ‘boot failure’. I also try changing my BIOS to UEFI and again the USB flash drive did not boot. I even tried placing the Win 10 iso file on a Ventoy flash drive and again, the iso would not boot.

At this point I either have a bad iso file or need to do more reading on creating an bootable USB, but all my other Linux iso’s worked fine.

Howard, that is weird?
The Mint procedure should have worked… or maybe it only works for Linux isos
Only thing I can say is try converting it to a hybrid iso… take a copy first, the isohybrid procedure is destructive and irreversible.

I now realise why the flash drive step is necessary… it is a traditional install iso with an install script, not a live filesystem like you get with modern linux distros.
Copying it directly to the disk only works for a live filesystem, and then you have to add grub to make it bootable.
I am so slow sometimes.

Sorry I cant think of anything else.
I looked at the itsFOSS guide. It says you have to format the USB drive.
That raises other issues… I think if you format it with MBR partition table, it will only work in legacy mode… not sure
There is something there about windows in a dual boot with legacy bios requiring mbr partitioning. Thst is not quite the same as making a flash drive.

I checked the SHA256 and the file I D/L’ed is good. I even try copying the Win 10 ISO file to the flash drive using the dd command. But again I got “Selected boot device failed”. So, I am about at the end of my rope.

Tomorrow, I will try your suggestion of converting the file to hybird.

Something else. Did you try just copying it with dd… without formatting the flash drive. ItsFOSS says format it, but I dont see why, dd would just overwrite any formatting?

More thoughts
I think 2 things are getting confused

  • making an install flash drive
  • making a bootable live flash drive

That FOSS article is about the latter.
You are saying we need to make the install flash drive first, then use it to install windows onto the external USB disk. … I agree

So forget the FOSS article. Just burn the iso to a flash drive with dd, or to a dvd with xfburn or brazero.
If you use dd to a flash drive, you might still,hsve to use isohybrid first. For a dvd it doesnt matter because dvds have their own way of booting builtin.

Just found a interesting post on creating Win 10 USB from Linux.

Also to convert the file I just ‘isohybird filename.iso’ ? No options needed?

easyt@7040:~/Downloads$ isohybrid Win10_21H2_English_x64.iso
isohybrid: Win10_21H2_English_x64.iso: unexpected boot catalogue parameters

Update: I tried the conversion and got the above error message.

Yep, no options needed.
take a copy first. It overwrites the iso file and you cant reverse it.

I read the article. It explains why eltorito isos are not bootable on a block device. They are basically dependent on the dvd reader to boot them.

Also, note I added stuff to previous reply

We are getting there

Last word:

Be careful using dd
The ‘safe’ way is

  • unplug the flash drive
  • lsblk
  • plug in the flash drive
  • lsblk
  • compare the 2 lsblk outputs. The extra device name of the second one is the flash drive… lets say sdx
  • do the dd with of=/dev/sdx… make sure you get ‘x’ right. … if it is wrong dd may overwrite some other valuable disk

You dont need to preformat to use dd

Hi !

I’m not a he, Hada de la Luna means «Moon fairy / Fae» in a Latin derived language I like (I’m using 2 of those languages)

I’m intending, since inception, to create a 1To USB bootable and persistent WTG for my studies as I need storage and install space but don’t want to have a MS windows PC. I have 5 Linux machines, none of them able to stand a recent MS windows OS and don’t want to buy a new machine for 6 month use (budget and desk are too small).

Your dialogue is confusing : what I’m suppose to type and in which order ?

Many thanks in advance for your clarifications…

Hi @HadaDeLaLuna ,
I am sorry for the mysogyny.

Yes the dialog is confusing. Howard knows more about Windows than me, and he is trying to help get you a reliable method for putting windows on an external usb hdd. That is why we have not replied directly to you today.

I suggest you give us a bit more time for Howard to try and replicate what you want, on his machine. Then we will know what works and should be able to give you precise instructions.

It would seem that your windows iso is not a live filesystem… it is an install disk. That means you first have copy it to a dvd or a usb flash drive, then boot from that and do the windows install to your external USB HDD. At the moment, Howard is having trouble trying to copy the iso to a flash drive, and we have to overcome that, before we can advise you.


1 Like

Hi @HadaDeLaLuna,

Sorry here also about gender. I by default will type ‘he’ if I do not know.

Also sorry about all the confusion, I spent about 3 hours or more trying to help with this problem.

Really, the only thing I saw wrong was you were using a HDD instead of a flash drive or DVD. While I continue to see what I can do, please get a flash drive of at least 8 GB and re-do and follow the instructions in the guide.

I am running Mint and maybe I did not format the USB flash drive correctly. I did not see the option to format it as a MBR drive. The guide was done using Ubuntu, the same system you have.

As a backup solution, do you have a friend that is running Windows that you might be able to use to create the USB flash drive?

Have a good day,