How to get black background back on Firefox default startpage?


#1

Testing LinuxMint LMDE 3 this weekend and it is wonderful! :heart_eyes:
Just looking for config setting to restore dark black background on Firefox default startpage.
Appreciate your help.


#2

Never used the dark background with Firefox so I am not sure what you are referring to. However, I found some suggestions on the web, tried them out and here is the working solution.

Type about:profiles in the address bar. In here, click on the Open Directory under the Root Directory option.

This will open a directory in the File Manager. Create a directory named ‘chrome’. In this directory, create a file named ‘userContent.css’

Add the following lines to this userContent.css file:

@-moz-document url("about:newtab") {  
    body {
        background-color: #000000 !important;
    }
}

Save and close the file.

Now restart Firefox and you’ll see that the start page is black now.

More customization for dark theme on start page of Firefox:

You may see a white splash when the new tab is opening. You can change that by going to Menu->Prefernces and in General settings, look for Fonts & colors:

In here, select black color for the background.

More ways to get dark theme on Firefox:

You can use add-ons that will change the color of the webpages to dark background (but not of start page). Try Owl add-on for this purpose.

I hope this helps you :slight_smile:


#3

Thank you for the many options and accompanying illustrations Abhishek!
You are quite the teacher! :wink:


#4

Hi Danielson,
I used the Add-on or Extention “Dark Reader” in Firefox.
U can switch the page from websites on or of like your disire.
Hope it helps


#5

Thank you Tron!
Would have never guessed there’d be so many possibilities.