Kali install on RPi4

I have installed the Kali distro on my RPi4 4gb, multiple times now. Every single time I have issues.

The ONLY command I run is “apt-get update && apt-get upgrade”. I follow all the subsequent prompts but after its ‘done’, dpkg gives me errors and bash doesn’t recognize any of my commands anymore(no clear, sudo, apt, ls, nothing). It also gives me input output errors, and if I reboot, then it puts me into kali tty. Any suggestions as how to fix this? I have tried multiple versions, multiple times to install the os and update and every time it does the same thing…

Follow the advice given here. As you are stuck on a fresh installation anyway, you might as well add the w option.

To do that, you need to plug the microSD card into your computer with working Linux on it. If you only have Windows available use Rufus, format the stick while ticking on the “Check bad blocks” option under Advanced Options.

That said, I do not see a Raspberry Pi version here. Did you get a Raspberry Pi image of Kali Linux or did you just use the armhf version? The armhf version is not always compatible with Raspberry Pi, especially the armhf respositories. You should check up on that, as well.

1 Like

I got the raspberry pi arm image from kali’s website. I can get it installed and browse around in the terminal and do normal stuff, but when I try upgrading or installing stuff is when I get issues. I will give the reformat a shot and see if that fixes it. I have formatted the SD multiple times though but I haven’t done anything about “bad blocks”.

1 Like

Formatting at first just applies to a small portion of the medium. The majority of it is untouched, that is why you can sometimes format a medium a million times and it will never show any issues. That is what you need something like badblocks for, which evaluates the entire medium, from beginning to end.

1 Like

well I am doing a double pass for bad blocks with rufus, although I had no clue it was going to take as long as it is or I would have chosen a single pass…oops

1 Like

If it is just at the beginning, I think it is still worth to cancel and start anew with a single pass.

1 Like

Nope that didnt fix it…

after running apt-get update && apt-get upgrade -y i get a huuuuuge list of errors…
This is more or less what happens every time I try this…

And now virtually no commands work… hence why I need to keep reflashing the OS…

a couple of answers to a quick search (not exactly your situation, but might be worth a try) suggest running apt clean before update. can you get to a tty?

This was new. I dont have a photo of it specifically, but I help Ctrl Alt Del, and then I got a red x error message saying that shortcut doest work. I clicked it and my whole screen went gray.

I then tried Alt and all of the F keys trying to get a terminal, and then something popped up that almost looked like it wanted me to enter 3 octets of binary, it was just a bunch of squares. I clicked one of them and then it brought me here…

I managed to get to a tty

i am seeing both card and fs errors listed there.

So, is the SD card the culprit? Because thats what Ive been leaning towards. I just dont understand why I can boot up the system, use it as normal, but as soon as I try doing an upgrade I have issues, I figured if the card was the issue it wouldnt even work to start with.

i’ve had void throw btrfs errors on an ext4 partition after an incorrect grub setting on my part so i don’t think any one error message is definitive. the quickest test i can think of is to try a different install image and see how that goes.

You have to use a different microSD card and see how it goes.

I have tried different install images and all return the same result. My best guess was the SD card. I should have a new SD by later today or tomorrow. Ill report back if that’s the fix or not.

A new working microSD card should be the solution.

Not sure about Kali on RPi4- but - there are a few Linux distros that work on RPi3 but not 4…

If it was me - I’d probably go raspbian (10, Buster) then install the Katoolin “doohicky” - which adds a repo and menu system for installing most (all?) of the tools Kali provides…


Kali does work on the 4. There are a few tutorials or videos featuring it, and there is an official image from Kali for it.

As for the new SD card, it didn’t give me the same errors this time but I got thrown into a weird black screen after the upgrade that was flashing between the mouse pointer in the center of the screen, and the text cursor in the top left of the screen. I managed to get a tty and ran startx, that got me back to my desktop, but the icons for trash, file system, and home are just red x’s. I opened a terminal and tried running the upgrade comand with a flag of -f thinking maybe that last time was just a fluke…well se if I continue to have issues…perhaps my pi board isnt good.