Mouse cursor keeps jumping around


#1

I have Kubuntu 18.04.

Issues with my mouse cursor jumping around. I have googled it but have not found a permanent fix.

I shake it a bit and eventually it stops

The last time I unplugged it and put it back in and that fixed it.

I use a usb plugin type mouse.

Is there a terminal function or package manager function I need to use to test it etc. I have checked all the mouse functions.

Would disabling my touchpad fix it?


#2

It’s a bug in KDE which I could fix by upgrading the system at some point. The issue is that you probably have to wait a while until the update gets available, because you are on a comparatively more stable branch which means they won’t just give you the newest packages. My version is currently 5.14.3 while yours is 5.12.4. Until I got the update, I was just pulling out and pulling in the cable.


#3

the tried and true “have you tried turning it off and back on again” lives another day :slight_smile:


#4

I disabled my touchpad and will see if that helps. Once when it was blinking I pulled the mouse off and the light kept blinking so it is not the mouse.


#5

It’s a touchpad problem
The pad is too sensitive you need to go in to the control panel and either switch off the pad or set it to zero
Strange idea but due to a setting on the pad on some models you may need to set it too high to stop the problem and not low … I know reverse logic but appears to be a track pad bug but not on all makes or machines
Helps with technical questions if you give make and model when asking so we can be clearer in answering or pointing at link


#6

I had this exact same issue on my desktop PC without trackpad.