To own-back external ext3/4 HDDs on new computer

  1. Assuming your backup drive is /dev/sdb as from the output of fdisk, but I don’t know why one of your drives might be missing in the output, as I only see 1 root drive for either the new or the old Ubuntu and 1 non-root drive.

  2. Gathering information.

sudo blkid /dev/sdb1
df -Th | grep "^/dev/sdb1"

Note the UUID value given by the first command as well as the file system type in the second column of the second command’s output.

  1. Backing up fstab.
sudo cp /etc/fstab /etc/fstab.backup20190728
  1. Creating mount point.
sudo mkdir -p /media/ashoke/MyBackupFiles
  1. Opening fstab for editing.
sudo nano /etc/fstab
  1. Add entry in fstab, using the correct partition identifier, i.e. /dev/sdb and UUID gathered from blkid, as well as the file system from df.
UUID=1234564567890 /media/ashoke/MyBackupFiles    ext4    noauto,user,rw    0 1

This mounts the drive at the given path as an ext4 formatted partition on demand with user permissions in read-write mode. I also enabled fsck to be run automatically on the disk, as it is your backup drive.

  1. Now try mounting the file system like this:
mount -U 1234567890

Verify if it has mounted correctly on the specified mount point and if everything works correctly, including permissions.
If it does not, then execute

sudo cp /etc/fstab.backup20190728 /etc/fstab

And start over at point 0. once again.

IMPORTANT: Make sure everything works, before rebooting, at all.