Ubuntu 18.04 installation problem


I tried to install Ubuntu 18.04 from flash disk on my laptop (Asus x550j) but each time it freezes at the “updates and other software” page.

I tried different ways: normal install, minimal install, installation without networking, installation with networking, but still the same problem.

I asked this question at “https://askubuntu.com/questions/1030103/ubuntu-18-04-installation-problem/1077634#1077634” but the candidate solutions consume much time. Besides, I’m really not used to Ubuntu to be problematic at installation. I’m afraid I run into the same problem in the future, and I’ll have to initially install Ubuntu 16.04, then update again.

I wonder if there is a better solution?


1 Like

You could try without internet connection - I know that worked when Mint 19 had a similar problem and that was the work around and once installed connect to the internet then and do the updates. Others here will know more about Ubuntu than I do, but this is one suggestion - If you get it sorted please let us all know for that will help others if they run into it

1 Like

As suggested earlier, don’t connect to internet, don’t download the updates. This may solve the problem for you.

1 Like

What wireless card is in your computer?

1 Like

Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

1 Like

Thanks guys for your suggestion, but I already tried installation without networking, and it still didn’t work

Did you try a different thumb drive? Try a DVD if you have it. I have had an occasional issue installing from a thumb drive.

1 Like

I ran into this. On a second attempt, I accidentally chose the base option (bare minimum install) and it worked like a champ. I was able to reproduce the issue on another machine (same model). My machines were an older thinkpad, but you might want to try it on your asus.

I had the same problem on one of my computers. Several others had no problem. The only thing I was able to determine was the hardware may have been too old for Ubuntu18. The PC it would never install on and would always freeze on had an intel 2 chip. The other two pc’s had intel 5 and intel 7 quad core chips. I was given all sorts of info about the monitors and graphics cards. I never changed my graphics cards. However I did swap out a monitor that worked with the intel 5 chip and it also froze when I connected it to the PC with an I2 chip. How old is the PC u r having a problem with

Try unplugging everything except the necessities - one monitor, keyboard, and mouse; ideally use the wired kind. Also try reflashing your thumb drive and/or using a different thumb drive. Try using a different/older sub-version of the installer. 9/10 times for me it’s that the installer sub version is bad or the write to the thumb drive is bad, or the thumb drive is garbage.

I had a heck of a time trying to get Ubuntu 18.04 to install on my Aero 15x which has a Gigabyte mobo. It would freeze up at various points of the install. One search suggested installing laptop-mode-tools package and that fixed the freezing. Good luck.

Thank you Chris.
I tried 2 flashes but both failed. But I think I should try another installer

Thank you Jim. I should try this solution. May you please tell me how to install it before, or with, the Ubuntu 18.04?

I installed it while running the live usb but prior to kicking off the actual installation process. I ran the usb install with network connectivity, opened a terminal and installed it(sudo apt install laptop-mode-tools). After the install completes make sure it’s running by typing “sudo /etc/init.d/laptop-mode restart”. You can see if it’s still active by entering “sudo laptop_mode start”. I then was able to kick off the actual installation which completed without it freezing; that is until it tries to reboot at the end. Another hard power off and then I was able to boot from the hard drive, update the install and it seemed to stop the freezing. I hope this helps.

1 Like

Ubuntu has problems with installing updates during the installation for years now. Seems like they somehow can’t get it to be fixed. Just turn plug out your LAN cable and tick off any extra goodies during installation. This usually does the trick.