Ubuntu 18.04 not recognizing kbd and trackpad

Specifications

→ Add the output of inxi -Fxmz command here!
→ Add the output of for f in $(find . -maxdepth 1 -type f -name 'dmesg*.log'); do echo "${f}"; printf '%s\n\n' "$(<"${f}")"; done command here!

First, install dependencies:

→ apt update
→ apt install -y dnsutils traceroute hping3 netcat tcpdump

→ ip a
→ ip route
→ traceroute 8.8.8.8
→ nslookup example.com

Additional Information (if applicable)

  • Software title | (E.g. Nextcloud)
  • Software version | (E.g. softwarename -V)
  • Was the software title installed freshly or updated/migrated?

A fresh version of ubuntu 18.04.4 Desktop 64-bit was installed on Toshiba Satellite Laptop via a USB stick. Apt update / upgrade.

Steps to reproduce

  1. On successive reboots, about 3 out of 4 result in keyboard and mouse not working. A USB kbd/mouse does work. Note that USB items were not installed during the install or reboots.

Expected behaviour

Actual behaviour

  • No keyboard or mouse on 3 out of 4 reboots. Random.

Extra details

  • ls -l /dev/input/by-path/*-kbd does show an AT keyboard file using event3
  • but xev and sudo hd /dev/input/event3 do not show any key press activity.

I’m poking a whale with sticks here, but I guess it could be some sort of race condition. Maybe 2 conflicting daemons fight with each other on bootup. If the first wins, your system is fine, if the second wins, your system is not fine.

Could you try using the hardware on another system with Ubuntu18.04 installed? It’s important as well, to exclude hardware issues, before diving into further problem analysis.

Speaking of Ubuntu 18.04…

Perhaps you could consider using a newer LTS version of Ubuntu, like, for example, 20.04 or even 22.04.
There are a lot of changes between the major version and it may also be the case, that your issue is simply fixed with a newer version.
It’s a possibility you should check out, especially if your Ubuntu 18.04 wasn’t yet really used a lot.

1 Like

In my experience I have noted that ALL computers run on smoke. If you let the smoke out, they don’t run anymore very well if at all.
Has there been anything spilled on the machine?
When was the last time you cleaned it up?
Have you tried a live usb boot drive?

1 Like

Thanks, 7Blade, for you insights!
Problem solved with a grub directive; i8042.nomux=1