Ubuntu 23.04 Experience

I moved from Zorin 16.2 to Ubuntu 23.04 the other day just to try it out for a while, and when the installer asked me if I wanted to include two types of third party software I put the affirming check mark on both of them. the installation went smoothly. When I was setting up my system, I tried operating my network printer / scanner and to my great surprise, BOTH OF THEM WORKED “right out of the box”. That has seldom if ever happened before, with any distribution, especially with the scanner. Kudos to Ubuntu for that. The only “issue” I’ve noticed so far is that two of the apps that I installed have pop-up windows with all the text characters replaced by empty rectangles (Bitwarden and Nimblenote). It’s hard to know what to click on when there’s no text. But the working printer and scanner more than make up for this one problem. Otherwise I’m quite happy with 23.04.

1 Like

Hi Jim,
I have had that. I think it is one of

  • a locale issue

  • a font issue

    See if you can find anything in the config files for those packages. It is not a global problem, it is package specific.

I like the printer working out of the box. Never seen it. Things are improving in Linux and Ubuntu is one of the leaders.


Hi Neville, thanks for your reply.

I looked in my home directory and there are no hidden files for bitwarden or nimblenote and in the .config folder there are no files with those app names either. These are both snap apps, and in /home/jim/snap there are folders for each or these apps, and in sub-folders of the apps there are config folders, I saw one file named fonts.conf but I have no experience with this sort of thing. Next step?

I am as puzzled as you. I do not know what to tell you to look for.
Maybe someone else knows.

I think it displays those rectangles when it cant find the required font.
What is in that fonts.conf file? Does it tell you what fonts are required for those popups?

I thought a snap app was supposed to be self contained so that it always works? Therefore it should supply its own fonts, not use the system fonts. Therefore the snap pak must be faulty. I dont know what you do about that… complain to Ububtu, delete the snap and get a flatpak or an appimage instead , delete the snap and reinstall ., get a package version of those apps, … does anyone know what to do?

@jimofadel ,
Looks like you are not the only one with a defective snap pack

Another clue: In both apps that show this problem, it is the “Are you sure you want to delete?” pop-up window that lacks a font. In Bitwarden it is deleting a login (mouse click), and in Nimblenote it is deleting a note (control-d). The two pop-ups are very similar and may be common code. I’m not going to spend any more time on this though, I’ll just use Zim instead of Nimblenote, and in Bitwarden I know where to click to delete, even without the text. I imagine this will get fixed by Canonical or the app developers eventually. Thanks again for your suggestions and your service to the community.

Good decision, Jim.
I think snaps are unfathomable when it comes to bugs.
Make do with your workaround , and let Ubuntu worry about it.
You might consider reporting it.

This has been the case for me with my Brother MFC since Ubuntu 16 at least…

Don’t have to lift a finger - look in Gnome Settings Printers, and there’s my Brother MFC!

Note : I don’t use it as a scanner from Linux or MacOS… When I scan stuff I scan it to an FTP “share” on my NAS - which is also shared via SMB and NFS (so I can look at the scanned documents / images using Nautilus or MacOS finder).

Same experience on Pop!_OS 22.04 - which is hardly surprising as it’s mostly Ubuntu…

One thing that I have endless problems with - on Oracle Linux 7 - the brother drivers are 32 bit - and the dependancies prevent patching, so have to remove the Brother (downloaded from Brother) i386 drivers and dependancies - patch - then re-install from RPM files… PITA! This is for work, we use CUPS to print from an ERP “tool” specific to power utilities.

Brother on Ubuntu = GOOD!
Brother on Oracle Linux (and probably Red Hat) = garbage!


My Brother is like that on Debian.

What happened to Postscript printers? They always install so easily… not completely automatic, but a few simple CUPS clicks.