VMWare Player 14


#1

I have been experiencing a hard system lockup when starting VMWare Player 14 and loading a VM of Win10. It works fine after a reboot (VMWare starts, Win10 VM loads and starts OK, and it’s all usable) but on the 2nd or 3rd time (that is, I shut down the VM and some hours or days later, start VMWare and Win10 again), once the window pops up showing the VM loading progress, my system halts. No mouse response, no keyboard response, the system monitor graph stops, and the clock displayed at the top stops.

Found that VMWare had a new point release so I installed it (through the VMWare dialogs). The next attempt to start it gives an error message that it cannot find the kernel headers for 4.17.0, the kernel version I am running. Some searching came up with some diagnostic steps and when I tried these, I found that indeed I did not have the kernel headers and found some discussion about a bug in 4.16.3 but could not find confirmation that this was causing my issue. I installed the Ubuntu Kernel Update Utility (ukuu) and installed the latest kernel (4.19). Rebooted OK and started my normal apps (T’Bird, Firefox, Excel via Wine, etc.) OK.

Starting VMWare now gives me an error that I don’t have the latest version of the C++ compiler (gcc, g++) - V8.2. More searching (‘install gcc 8.2’) and an easy installation followed. Tried VMWare and it started, recompiled the kernel modules it needs to run, and Win10 loaded and runs OK.

I don’t know yet if this solves the hard system hangs but I will keep an eye on this in the coming days.