What is a decent, low cost graphics card for dual monitor application? [ Resolved ]


@ Martok

Graphics: Card-1: Intel HD Graphics 530 bus-ID: 00:02.0
Card-2: NVIDIA GK208 [GeForce GT 710B] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting,nvidia,nouveau (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
OpenGL: renderer: NV106 version: 4.3 Mesa 18.0.5 Direct Render: Yes

I’ve installed LM19 to my Dell and the inxi -Fxz gave similar reading of having two graphic card entries. Intel 530 and the ATI card. There is no proprietary drivers on offer for my ATI card.

Whereas my new rig with the 1060 Nividia card only has the one line. As you can see from the second picture and Nvidia settings.

Out of curiosity what does your Driver Manager and Nvidia settings tell you.


Upgrade to Ubuntu 18 will not boot [ Not Solved ]
Might I need new hardware? [ Not Solved ]

I can’t change it. Whatever they had me do in the Mint IRC, I can no longer change the driver.

Might I need new hardware? [ Not Solved ]
Upgrade to Ubuntu 18 will not boot [ Not Solved ]

Okay, this is going to be a suck it and see, exercise.

This website gives instructions how to remove Nvidia, but if you have since deleted/lost the original Nvidia driver file with the download from Nvidia. They suggest using another driver.

You will need to do a dkms status and possibly remove the old dkms instances, before you can install the recommended proprietary 390 driver via the driver manager.

The other option, should you be unable to correct the previous instruction and advice from Mint IRC, would be a fresh install, do the normal update and upgrades, then reboot, then use the the recommended 390 driver and reboot. This should solve your current problem.

I have read on numerous occasions, it is strongly advisable to stick with the proprietary driver, as it works.



Thank you! I’m backing up my system and trying it now.


Here is what happened when I executed sudo apt-get purge nvidia-*
I put it in termbin so it wouldn’t clutter this chat


I then ran “dkms status” and this was the results

nvidia, 410.78, 4.15.0-39-generic, x86_64: installed
nvidia, 410.78, 4.15.0-42-generic, x86_64: installed
nvidia, 410.78, 4.15.0-43-generic, x86_64: installed

For the hell of it I ran “sudo dkms remove nvidia-current-updates/410.78 -k 4.15.0-39-generic” this was the results:
Error! There are no instances of module: nvidia-current-updates
410.78 located in the DKMS tree.


Error! There are no instances of module: nvidia-current-updates
410.78 located in the DKMS tree.

You could download 410.78 driver again from Geforce and use their shell script to remove all instances of dkms.

Or check if you can remove them with Synaptic package Manager. Failing that it sounds like a fresh install.



I’ve sent you a PM


Coming late to this have you tried upgrading to 19.1 which you can do through update manager as I know that some problems have been fixed and if you also checked the kernels? 4.15.0. 45 is the active one and there are 4.18 on there as well which you could try. I knew that others were having problems with them in the past and I thought that had been fixed. This link probably covers everything, but it might be worth a look at


@Martok Any updates?


Sorry that it’s been a while since I posted a reply. I actually didn’t play around with my PC for a while. I was going to order another graphics card, I’m glad I didn’t. I was running 8 GB of RAM. I ended up installing 16 GB of RAM, and now it’s running perfect.