XFX 680i LT MB with XFX GeForce8500GT Hangs Up when restart after initial installlation

New to everything Linux. After using Xfce on a Dell Pen M laptop for a while, I am trying to convert a WinXP machine to a Linux one. But after completing the Ubuntu 22.04 installation, the requested Restart hangs up the booting with a frozen mosaic pattern. Subsequently also tried other distros, Fedora, Xfce, and Cinnamon(all 32 bit), with the same mosaic. Used “nomodeset” trick too. Any insights?

At the risk of asking an obvious question, did you format the HDD and erase the Windows installation? That would be the first step in converting an XP computer. Once things are empty and clean, a fresh Ubuntu install should work fine.

Thanks, Berninghausen. I used the Rufus/USB boot which, I assumed, would’ve reformatted the HDD. How could I format an HDD prior to the installation?

It should be an option in the installer. It will say something like ‘erase and use entire disk.’

If this XP machine is 32bit, you need to look elsewhere for a Linux OS, Ubuntu stopped
support for 32bit awhile back.

1 Like

You might be able to get 32 bit Xubuntu, still…

Just checked - Xubuntu stopped i386/i686 (32 bit) releases since 18.04.5… Note 18.04.5 is an LTS and probably not EOL (end of life) till around 2025? Maybe later?

So - I’d recommend you check out Xubuntu 18.04.5…

Sounds like you need 32 bit anyway - @4dandl4 is “on the money” :smiley:

There’s also Debian (I’d recommend XFCE Debian), or Mint…

Thanks, everyone. So far reformatted the HDD after pulling it out. Tried to boot from both Fedora and Xfce(both 32 bit). It stuck either at the Fedora logo or at the first open but blank window for Xfce. I will give the 32bit Xubuntu a shot later. Good night!

Can’t help but think that there’s something in the BIOS that you missed–secure boot, boot sequence, or something else mentioned in the ItsFoss library of assistance articles.

Also, are you sure it’s a 32 bit machine?

Thanks again for trying, Bernignhause. The MB can go either way, but CPU is a Core 2 Duo, which I remembered was 32 bit one.

The XFX GeForce8500GT is old Nvidia and probably will not be supported by most distros. The only Linux driver that might work is the nouveau open source driver. The only distro that might even come close to working is LFS or Gentoo, I have been able to use Zorin 32bit, but I do not think you would like the way it runs or even if it will open your graphics.
If you had left XP on the machine, then Linux would at least have recognized your hardware for dual boot with XP. You might also try the Trisquel distro and see if it will open your graphics. Good Luck!!!

Say what – :hushed:

The older the graphics card, the more compatible it becomes. The older cards are most compatible, as slow open source development had decades to catch up including support for them.

Additionally, the 8500GT is quite popular. Have seen this model way too often.

Therefore, this card should have great compatibility with any distribution.


Same thing with Windows software and games. The games which are at least 10 years old most of the time work the best in Wine. Same goes for ancient Photoshop versions. They all work excellently in Wine. With newer versions, it gets worse and worse.

Post what you want, but Linux support for old graphics is not the best, been down that road too many times!!!

It’s simply not true, though. Running a brand new NVIDIA card properly on Linux is, as of now, tougher than watching Sisyphos 24/7. Not to mention the lack of compatibility with Wayland.

On the other hand, older NVIDIA cards are pretty fine. AMD still rocks the Linux world, but older NVIDIA cards at least work properly.

And when was the last time you have tried a Linux install on one of the old XP machines? They
should all be put into storage.



Very much so.

As a pseudo-hobbist who dabbles in Linux, doing this, getting some old window machines to function OK with smarter Linux, could be a good way to learn, as well as a way to prolong the parts’ utilities.

1 Like

That may be true but it sometimes is not worth the effort or time!!!

Probably / maybe ignore the stuff I wrote earlier - if you can boot the live image and run the installer, and most importantly - INSTALL - then your machine must be 64 bit capable…

Pretty sure nearly all of the core2duo were 64 bit - I seem to remember a few odd ones like the “coreduo” wasn’t. e.g. you can’t run 64 bit OS X on a coreduo, but you can on a core2duo…

I also agree with @Akito, about old hardware - FAR FAR better support for “legacy” stuff in Linux than on Windows… and most times its nearly plug and play…

I’ve got a pair of GeForce6800 in SLI mode on an old motherboard, and the great thing about the GeForce6800 (and probably the 8500) is you could easily kinda “hack” them to appear as Quaddro Pro GPU cards… They ran fine anyway - for me… But I don’t really use that board anymore - probably haven’t booted it for years - 'cause it’s only DDR2, the CPU is only dual core (AMD) and I only have 1GB DDR2 modules, so max I can run on it is 4 GB… All my other stuff is at least capable of 16 GB with DDR3 4 GB modules…

I see that chipset is NVidia NForce (2) - I have never run Linux on an NForce chipset motherboard, so I can’t comment. I had a couple of them in the early noughties, mostly ran either Win 98 or Win XP on them (probably XP) - but I think that was NForce 1, which was defo ONLY 32 bit… i.e. from a few years before commodity 64 bit CPUs came from AMD or Intel…

1 Like

After tried several distros, including Xubuntu 18.04, the frozen screen with the same pattern of mosaic happened again and again. It seems clear now that the display setup is not compatible with the any one of the distros. The only setup process I ever finished, twice, was the installation of Ubuntu 22.04 that froze only when I restart after the completion of the installation. It froze right after the distro logo was shown for all other distros I tried to install.

BTW I also had 2 x 8500 in SLI in XP. I attempted to install each distro once with the SLI bridge, once without, which made no difference.

Thanks, guys. Good night!

Sounds like a whole driver family is simply not being supported, at all. I experienced this mostly on laptops. It shouldn’t happen that often with actual computers, but I also encountered that in my life. Of course, mostly with newer hardware.

1 Like