Xubuntu 16 instabillity


#1

I’ve kept xUbuntu 16 on an SSD fitted to my 2008 Toshiba Satellite and maxed the memory to 4GB.
However I get, most days, either a grey screen or the machine re-boots.
I tried trimming the drive a day or so ago and thought maybe it was improved but…

I did upgrade to Ubuntu 18 variant but it meant reconfiguring my old hardware (Brother MFC 5860CN)
for printing (no problem) but scanning I ran out of patience with.

Any diagnosis appreciated. Thanks. Bob F.


#2

Hello Bob,

Can I make this post public?

The idea of the forum is that you get help from more people and your problem can help others later. A private message is not useful to others.

So, can I make this post public so that everyone can see it?


#3

Hi Abhishek,
yes, please do. I am a bit groggy on forums I’m afraid.

Thanks very much for getting back to me.


made this topic public #4

#5

Could you exactly describe what exactly you’re doing with the machine and, maybe, what it does right before the error occur, and if possible, what error occurs after which action? Be verbose.


#6

Hi Akito thanks for responding.
xUbuntu 16 latest patch.
Toshiba Satellite 350 series
dual core; 64 bit, 4Gb memory.
120Gb SSD.

Most times I am browsing the internet. There are several tabs loaded, say 10.
The issue is not specific viz it is not after any routine input action, however
most times the cpu fan is running flat out so maybe a hardware issue?
It has occurred a few times whilst making input in Writer.
If it happens again I’ll screenshot the boot screen listing the post routine.

The issue is as previously stated:
Desktop greys out, freezes.
On three occasions the machine rebooted,(recently, last 4 weeks) no grey screen or warning no freezing beforehand.
I had the same issues after upgrading to Ubuntu 18.


#7

If you can, open the laptop up and do a full intense cleaning by removing all dust hanging around. If you don’t know how to do that, then use a vacuum cleaner onto the fan outputs.

Yes.


#8

running htop may help us understand if this is a ram or cpu issue. posting the output of dmesg --level=err,warn can also be of help. this output can be lengthy. to take up less space, there is a hide details option in this post creation area. if you click on the gear wheel icon at the far right above, the popup menu lists the Hide Details option. clicking on that will insert the text [details= “Summary”] followed by the line “This text will be hidden”. i have replaced “This text will be hidden” with some output from running dmesg on my computer so you can see how it looks.

Summary

sample dmesg output:

[ 1806.394494] print_req_error: I/O error, dev sr0, sector 12648448
[ 1806.582591] print_req_error: I/O error, dev sr0, sector 12648500
[ 1806.582601] Buffer I/O error on dev sr0, logical block 3162125, async page read
[ 4475.330510] VFS: busy inodes on changed media or resized disk sr0
[ 4503.614511] Suspending console(s) (use no_console_suspend to debug)
[ 4504.689770] IRQ 27: no longer affine to CPU2
[ 4504.713694] IRQ 23: no longer affine to CPU3
[ 4504.713700] IRQ 24: no longer affine to CPU3
[ 4504.846915]  cache: parent cpu1 should not be sleeping
[ 4504.978910]  cache: parent cpu2 should not be sleeping
[ 4505.110910]  cache: parent cpu3 should not be sleeping
[ 4505.784423] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[ 4505.811359] tpm tpm0: A TPM error (6) occurred attempting to read a pcr value

#9

Hmm… could be that a particular program is misbehaving.

Here is my advise. Keep a terminal window open and run top command in it. When your CPU fan starts going crazy, look at the terminal and see if there are some processes that are using more than 50% of CPU or Memory.

Identify the culprit process and kill it. If the same process(s) repeating causing the trouble again and again, maybe you should upgrade/uninstall it and use an alternative (if that’s an option).


#10

Firstly, many thanks to all who have offered suggestions.

I installed and ran the scripts to check the machine out and found that very interesting in itself.
I can see that there are hardware issues which may cause the problem - maybe the old Laptop just can’t cut it. I had installed, some time ago, an Express card so I removed it to eliminate same.
Not had the machine on for any duration but will try in the next few days.

I did clean out the board and fan although I had done this not long ago.

I am not at all put off by this issue. I have dabbled with Linux since about 1996 but never really got to grips with it. Much has now changed.
Personally I think it’s a fantastic OS. I just wish I was 50 years younger having the time to start over.
Thanks again,

Best wishes etc,