4k Video Downloader on Ubuntu 18.04 MATE

Hi All,
Has anyone got any experience of 4kvideodownloader on Ubuntu MATE 18.04?
I installed the ubunutu 64 bit version from the .deb file on https://www.4kdownload.com and it installs OK and adds itself to the menu. However when I try to launch it from the menu nothing happens. Using the same menu entry I right click on it to add to the desktop and the panel. Launching from the desktop and the panel works OK. Does anyone know how to get the menu entry working please? The properties on the menu item and the desktop launcher are identical!
Many thanks,
Tony

On KDE I had a similar problem. Try recreating the icon by deleting it entirely and make a new one.

2 Likes

Tony, welcome to our community. I don’t have an answer to your question. Have you looked on the It’s Foss sites to see if there is answer on them, or perhaps @abhishek can direct you in the right direction.

1 Like

Hi Akito,
Thanks for yuor suggestion. I tried deleting the icon from the menu and recreating it, but unfortunately this didn’t make any difference
Hi ElectricDandySlider,
I can’t find anything about this problem anywhere on the net :frowning:

2 Likes

Perhaps one of our community members will be able to come up with an answer as you have not found any answers yet. There is a lot of knowledge on here that we like to share.

2 Likes

@tonyb12,
I don’t know the solution but I found some similar fault and could be a tip to solve your problem:

1 Like

Hi Tech_JA
Many thanks for your help. I can’t see anything wrong with the mate-applications.menu files although I must confess that I don’t really understand them. However your suggestions got me thinking and I tried using different panel layouts from MATE tweak.
Launching 4kvideomanager worked using all layouts except Redmond (which I was using) and I got the same result by installing 4kvideodownloader on a live USB system. The suggests to me that my installed system is not corrupted.
As far as I can see Redmond is the only layout that uses the Advanced MATE menu and so I added this to the Traditional panel layout and the app wouldn’t launch again. So it looks as if the problem is with the advanced MATE menu, although how to fix it is anyone’s guess!

Kind Regards
Tony

2 Likes

You probably can report this to the developers.

3 Likes

I don’t have MATE desktop so reproducing the problem would be an issue for me.

Since you have already pin-pointed the issue, I suggest that you inform the developers through their community forum: https://ubuntu-mate.community/

3 Likes

Hi Abhishek,
Thanks for the link. I’ve raised this issue with the MATE community as per your suggestion.
Regards,
Tony

2 Likes

I use it on Linux Mint 19.1 - Mate.
For me it works perfectly.
(Version 4.7.3.2742)

3 Likes

Well that is an interesting turn on this subject - thanks for that so it could be a Ubuntu Mate problem not an issue with 4K Video Downloader

1 Like

Hi All,
Thanks for your help and support with this. The MATE community found the problem which is actually with the 4kvideodownloader.sh file and have provided a workaround which is:

sudo sed -i ‘s/^ //’ /usr/lib/4kvideodownloader/4kvideodownloader.sh

in case anyone else has this problem. I’ve informed the 4kvideo support team.

Their full response is below FYI:

  1. Analysis

I can confirm that it does not start from Advanced MATE Menu, but starts normally from Brisk Menu, Main Menu and Menu Bar applets and from Panel and Desktop launchers.

We can locate and investigate its desktop-file:

$ which 4kvideodownloader

/usr/bin/4kvideodownloader

$ file /usr/bin/4kvideodownloader

/usr/bin/4kvideodownloader: symbolic link to /usr/lib/4kvideodownloader/4kvideodownloader.sh

$ ls -al /usr/bin/4kvideodownloader

lrwxrwxrwx 1 root root 47 июл 18 20:39 /usr/bin/4kvideodownloader -> /usr/lib/4kvideodownloader/4kvideodownloader.sh

$ dpkg -L 4kvideodownloader | grep desktop$

/usr/share/applications/4kvideodownloader.desktop

$ cat /usr/share/applications/4kvideodownloader.desktop

[Desktop Entry]

Name=4K Video Downloader

GenericName=4K Video Downloader

Comment=Download online video

Exec=4kvideodownloader

Terminal=false

Type=Application

Icon=4kvideodownloader.png

Categories=Network;Qt;

What is strange - they have leading space in the executable file:

$ cat /usr/lib/4kvideodownloader/4kvideodownloader.sh

#!/bin/sh

LD_LIBRARY_PATH=/usr/lib/4kvideodownloader

export LD_LIBRARY_PATH

/usr/lib/4kvideodownloader/4kvideodownloader-bin $*

Its icon is always shown, it is shown in correct place. But Exec line is fails only for advanced menu.

From /var/log/syslog we can see the error message produced after clicking on menu:

tail -f /var/log/syslog

Jul 18 21:00:30 bionic org.mate.panel.applet.MateMenuAppletFactory[1305]: message repeated 20 times: [ TypeError: Couldn’t find foreign struct converter for ‘cairo.Context’]

Jul 18 21:00:35 bionic org.mate.panel.applet.MateMenuAppletFactory[1305]: 4kvideodownloader

Jul 18 21:00:35 bionic org.mate.panel.applet.MateMenuAppletFactory[1305]: [Errno 8] Exec format error

Jul 18 21:00:35 bionic org.mate.panel.applet.MateMenuAppletFactory[1305]: TypeError: Couldn’t find foreign struct converter for ‘cairo.Context’

I can remove error messages about cairo.Context by installing related python-packages:

sudo apt-get install python-cairo python-gi-cairo

But it does not help.
2. Solution

The real problem is leading spaces in shell file.
If we remove spaces, then program will start normally:

sudo sed -i ‘s/^ //’ /usr/lib/4kvideodownloader/4kvideodownloader.sh

You should contact the 4kdownload’s software developers directly to inform them about their error.

Regards,
Tony

4 Likes

Tony, can you mark this as solved now pleased with post (yours) which provided the solution. If you don’t know how to do so, one of we Admins can do it for you.
Thanks Kev

On my side it looks like this:

$ tail -f /var/log/syslog
 
Jul 19 06:53:46 Lenovo-Z51-70 org.mate.panel.applet.MintMenuAppletFactory[1218]: 2019-07-19 06:53:45 (140104126379904) [INFO] Launched with arguments: /usr/lib/4kvideodownloader/4kvideodownloader-bin
Jul 19 06:53:46 Lenovo-Z51-70 org.mate.panel.applet.MintMenuAppletFactory[1218]: 2019-07-19 06:53:45 (140104126379904) [INFO] Using locale hu_HU
Jul 19 06:53:46 Lenovo-Z51-70 org.mate.panel.applet.MintMenuAppletFactory[1218]: 2019-07-19 06:53:45 (140104126379904) [INFO] SoftwareUpdate::Manager: appId=4kvideodownloader, appName=4K Video Downloader, appVersion=4.7.3.2742, appCast=https://www.4kdownload.com/static/main/app/appcast/videodownloader.xml
Jul 19 06:53:46 Lenovo-Z51-70 org.mate.panel.applet.MintMenuAppletFactory[1218]: ADVERTISEMENT: HU:hu

And it works flawlessly…
So why does it work on Mint, and does not onUbuntu Mate?