8tb ext hard disk has light but not detected on my pc/linux

I tried to access to the seagate 8 tb data I collected since 2015 could not the drive has power light but my PC did not recognize it , on other 8tb I lost partition following communities I tried to restore this partition resulted in losing huge files on 2 folders I did not find on internet my problems solutions on both cases please advise by your detail on screen explanation my pc is the only window to spent my days (74 years old !!)


If you can, I suggest a professional data recovery service. They will need to do sector read on your drives. It’s very labor and time intensive. I’ve done it before but that was a very very long time ago.
Once that’s done I suggest investing in a cloud storage service. I use Pcloud and it works very well for me. Yes, I have had to recover files from it not too long ago. Long story. (73 years old)


Your only solution may be to use an external service but that does tend to be expensive so before you may want to try a few other options,

Sadly you did not say which version of linux you are using and if you have tried the built in disk mount system in the control panel.

Make sure disk is plugged into usb port.
Try another port.
Try another usb cable.
Have the disk connected and powered up before booting the computer.


Most computer repair shops would plug in the drive into a computer and tell you if it’s alive for free. Many senior centers have hobbyists who could help you. Most retirement homes have some volunteer hobbyists who could help. Computer help for seniors should be available to you locally.