A Story About Booting My Computer

Currently, I have Windows 10 Enterprise and Debian 10 Buster installed on my main desktop computer. I am forced to use Windows, because of

  1. work
  2. games
  3. trouble setting up 5 monitors to play well on Linux.

Since probably over a year or two, I have a very nasty problem with booting Windows. Everything is set up with GRUB2 and UEFI, as I usually did all the years I am multi-booting and yet only over the mentioned period of time it takes about 7 minutes to boot into Windows 10. Hibernation doesn’t work, neither does sleep. Not even restart works. The only things that work are shutdown and boot.
I already looked at the syslog during the operating system’s start up but it didn’t really make me smarter. All it showed was how long the boot time took, I didn’t find any indication for the cause of the prolonged boot time.

This problem persists for such a long time, because it is very nasty. The nastiest thing about it is the debugging process. Basically, if I wanted to fix that issue reliably, I’d need to test out different possible solutions and reboot every single time when applying each possible solution. So every try would take up about 7 minutes of not doing anything on the target computer, even though I need it for the reasons shown in the beginning.

Well, maybe your computer is just too old to run this rather new OS properly.


Intel Core i7-8700K
Corsair Vengeance DDR4 2x8GB (16GB)
NVIDIA GeForce GTX 970
NVIDIA GeForce GTX 970
Transcend 119GB TS128GSSD320 (SSD, Windows System Drive)
Transcend 119GB TS128GSSD370S (SSD, Linux System Drive)

Additionally, I have an 8TB backup drive attached, which might cause slow downs during boot, but in 2019 nobody can tell me that the main OS of most people on earth can’t handle a bigger than usual disk.

On the other side, we have Debian Linux, which takes about 10 seconds to boot and it is actually able to hibernate, sleep and restart.

I posted this issue in fora, including superuser, already, but nobody could help in such a vaguely perceived issue.

I’m out of ideas and need a solution that works without me rebooting all day long to fix this issue.


Reading carefully what you have put here. I am going to make this suggestion. It could be that somehow Windows has become corrupted, it does happen to it as I have uncounted that before. Having looked at your specs, that would be my “gut feeling” to look at first.

You may well have already tried these options, which given your experience you probably have done so. One would be to go to the drive that its on and right click on then chose, the scan and fix option there (not exactly sure if that is what it is called, but something like that). The other option is to to doing a system repair in windows which is found in the Windows Settings.

Microsoft used to have a Fix-it tool (the way they wrote it) I am not sure they still have which would sort things out. If you head over to the Microsoft site, it might still be there.

My last suggestion is to head here https://forum.thewindowsclub.com It is by far the best forum for Windows and is run by long standing MVPs . I am as sure as I can be that you will get the help there.

I hope you get your answer soon.

1 Like

Deleted by author today

1 Like

You’re right, it is disabled.

Pure UEFI, no CSM is allowed on any of my machines. I still remember days of trouble just because of this hell called CSM.

499 MB NTFS OEM Partition
100MB EFI System Partition
118.64GB C:

I can test that, when I will be checking solutions.

Both are essentially same, except Enterprise has a few more distribution options (don’t remember exactly). Most important difference between Home and Pro is the group policy possibilities, as well as the possibility to turn off analytics and telemetrics.


was this with the event viewer?

Yes, I used the Event Viewer.

1 Like

event viewer can be so very hit and miss. i have found even new installations throw so many seemingly important system errors that it is hard to figure out which ones to focus on.

at the risk of sounding overly simplistic, have you taken a look in msconfig to see if there is a bunch of extra nonsense (granted, 10 minutes with your specs would be a metric ton of the stuff) running at startup? it has been a while since i worked with windows, but my recollection is that even after programs were uninstalled properly that didn’t mean errant processes and services from them didn’t still run.

If I remember correctly, one of them is (some system) , where you can boot into another disk using your system, without windies secure boot and security getting its nickers in a twist.


Oh, yeah right, now I remember that Windows on the Go was only availble for Enterprise, wasn’t it? I think that’s the best feature Windows added since a decade. Ironically, I didn’t yet have a use case for it.

Its one of the redeeming features of Legacy mode, when I had a largish collection of redundant and surplus HDD’s, before selling them on eBay. I had an old Dell with a quick access, side opening, where I could swap out the HDD, install an OS, had about 20 plus different distros, with all the major DE, i.e LXDE, Xfce, Mate, Cinnamon, Gnome, TDE, KDE and Openbox.


could you do a test?

  • save all your work on WIN 10
  • open the command prompt as administrator
  • write bellow command and press enter:
  • Powercfg /hibernate off
  • shutdown your PC
  • Start again with WIN 10

I had a similar problem because of the hiberfil.sys ( the file where WIN10 writes everything before hibernates)

If you want to activate again the hibernate the command is Powercfg /hibernate on but have in mind your are writing a lot of MB (or BG) every time your PC hibernates and your are using a SSD disks

Please give the feedback…

1 Like


So this issue was becoming too much to handle, as it became worse and worse. When the booting process hit the 10 minute mark, I decided to renew the Windows. Just to test, I used the “Refresh” Windows option in the Windows 10 settings, which supposedly refreshes the OS installation entirely, as if you just did a clean installation. I of course chose the option where all my data an settings will be deleted.
Even after this “refresh” the same old issue remained. What a surprise, Windows lied to me and actually did not make a fresh installation, at all.

I got an entirely different Windows 10 image. After 15 hours and admitting of being knocked out by Microsoft Windoze, I managed to install this new and fresh image cleanly onto the SSD.
Now everything purrs like the sweetest kitty.

Every friend I asked was pretty sure it is just “my old SSD” or something like that. I was sure that it was just the Windows installation fucking up. Well and here we are now, I was right and my hardware is top notch, as I knew from the beginning.

Thanks Windoze. Thanks Microshit.


I know you’ve closed it, but this has been a problem with many Windows that I have had in the past. You start thinking it your hardware when the problem is with them and even their latest updates are causing problems yet again! You were right to go with your “gut feeling” and I find when I don’t that it takes me longer to solve than otherwise.
Any glad you sorted it out and everything is how you want it to be.