Analog audio output disappearing in Ubuntu 20.10

I recently had the issue that my computer wouldn’t play any sound through the analog output (headphones). It’s more: It completely disappeared from all system settings.

Digital output still worked fine and was visible in system settings.

Searching a bit, I found that many people have experienced the same issue. There are several “solutions” and theories about the cause of this issue floating around, however, for me, only one of them all worked:

killall pulseaudio; pulseaudio -k ; rm -r ~/.config/pulse/*

and rebooting the computer.

Whilst this actually leads to the desired result, I’d be glad if somebody knew about the reasons, why (and whether there’s a less brutal alternative).

Thank you.

1 Like

I’m not sure why this happens, but I solved this trouble in the past when upgrading from 18.04 to 20.04, simply configuring the AlsaMixer or PulseAudio from the Terminal with one of these two solutions:

sudo apt update && sudo apt upgrade -y && sudo apt install -y alsa-utils && alsamixer
(Explanation: First update/upgrade automatically the system, then autoinstall the Alsa utilities and mixer too, in case they don’t are installed on your computer).

Then, verify if something is disabled and enable it again. You need to select first the soundcard or input you want to verify, using the F6 key (if you’re using a laptop with FN keys activated in BIOS, probably you should use FN+F6). After you selected the correct source, then you can use the left/right arrow keys for selecting the channel you want to modify. Then you can in/decrease the volume for each channel using the up/down arrow keys or +/- keys.

If Alsa Mixer doesn’t solve the trouble (or you don’t want to install another mixer and use only the Pulse Audio), then try this… First verify Pulse is properly installed:

sudo apt update && sudo apt upgrade -y && sudo apt install -y pulseaudio pavucontrol
(Explanation: First update/upgrade automatically the system, then autoinstall the PulseAudio and GUI control too, in case they don’t are installed on your computer).

Then type pavucontrol on the Terminal in order to open the App or simply press Super key and search for PulseAudio Volume Control from the Applications Menu. Then you can configure the PulseAudio and repair some troubles you find without using the killall command, if is not strictly necessary to do this…

Hope that help you!
Benny.

2 Likes

Thanks a lot, @BennyBeat

Unfortunately, I had initially already tried both solution attempts you proposed, just the other way round - to no avail.

Fortunately, after my brute assault, the problem hasn’t surfaced again.

2 Likes

Glad to know your trouble is solved!!!
Cheers!

Actually, I already said so in the initial post …

I was just curious for an explanation.