Android tablet issues with screen

I know this is a Linux forum but as many of us also have a tablet and Android wonder if anyone has come across similar issues and found a solution
Screen ghost
bought a Lenovo tablet m10 the tbx606f been using it without issues

But during a internet connection yesterday the tablet begain a strange bleeping sound and a load of rrrrrrr appeared on the search bar I was not touching the screen or keyboard at this stage when that stopped my screen changed and it’s now ok left hand side but the righhand side is a off set image of left

Hard to describe

But it’s as if the screen is being duplicated but off set by 3 inch imagine underneath the t letter I can see a q under the y I can see a w etc

Thought at first virus issue so scanned with several different virus tools malwarebytes AVG avira etc all found nothing

Android Google scan from play store found nothing

I tried a restart same problem

I went to settings and did a factory reset same problem

I tried a hard reset with power and sound control but this comes up in Chinese or a similar language set which I cannot follow and I am unsure in case it is a different order to the English help sit info

Of course now out of warranty by 2 months

Would have to scrap it so looking for ideas

Appreciate your help

Did you get moisture in it?
They are very difficult to dry out. Our phone took 3 months

1 Like

All I know about Android tablets (from my experience with 2 Samsung Galaxy Note Series tablets, the 10" and the 12") is that they’re terrible, and hence why I prefer to use an iPad… What I hated most about those Galaxy tablets was hideous things like the infamous “boot loop” - happened on both… It’s why I stopped using the 12" one (I stopped using the 10" 'cause I dropped it about 2 feet and the WHOLE screen shattered - I did similar from even higher with an iPad [3rd gen] and it merely cracked the edge)… In BOTH cases, doing a factory reset fixed the issue - but - I lost data doing that!

Sorry… I have two iPads - a Pro 12.9" (circa 2018) and a 5th gen Mini which I mostly use to read e-books…

My Samsung did the same just kept rebooting and never got a fix hence swapped to Lenovo but different problem
Think I may just stick with Linux mint on netbook which continues to work after 16 years and so many upgrades since I stopped using xp now on lmde as it’s a 32 bit

No moisture as I was in bed catching up at the end of the day but thanks for the idea