Anyone familiar with Flatpak codes?

JSDP4Linux (installed) and have no idea as to resolving this message :

“Please run ‘flatpak permission-set background background me.timschneeberger.jdsp4linux yes’ and reenable auto-start.”

Entered it in the terminal a few times already, but nothing changes (still get same message).

Like all error messages, it was written by an alien and you have to read between the lines.

I dont think it was meant to be typed into a CLI
is it perhaps a shonky description of what to do in a GUI?
Can you anything in your GUI that might set flatpak permissions?
That bit


looks like an URL

I am out of guesses.
Those who write such things need to be reprimanded.

Running the command directly should work but not sure why it’s not in this case, however Flatseal is a GUI to also do these things in which could be helpful in the OPs case

That’s the flatpak package name, they follow a scheme of usually

@Nia ,
Thanks for the correction. I am not familiar with flatpak.

Do you have any idea why the command did not work?

Sadly not, I’ve had the same issue with the DejaDup backup tool as a Flatpak, granting background permissions but the app doesn’t recognize that the permission was granted and just asks to enable it again endlessly.

It seems like an issue with either Flatpak itself, or with the methods that the Flatpak packagers are using to check if the permission was granted.

@danielson one thing you could try is running flatpak permission-reset me.timschneeberger.jdsp4linux in the terminal and relaunching it and seeing if it gives you a popup asking to grant the permission when you try to open it again

1 Like