Barrier on client can not be edited

I installed Barrier as indicated in the article by Foss, it worked out of the box but now, the next day the server is up but the client is not . So I manually started client and same result. Tried to find a .config file, no luck. If anyone knows how to access the client please let me know.

Reading through the article it was written by @abhishek, so he’ll be the best one to answer this question I think

Just to confirm, both system are connected to same network?

Yes, never have a network problem, I also use NFS where one (the Barrier server) acts the server and the other the client.

I would appreciate some suggestions as to how to make it work or where to get the correct info to fix it.

Sorry for my late reply.

I would advise to check a few things:

See if the client has correct configuration, it uses the server’s IP address to connect and if that IP is correct

On server, see if the server configuration uses the correct hostname for the client.

Verifying these things is the first step of the investigation.

The client Barrier did not create a conf file, at least I cannot find one, the server is working OK. Desktop is Unity, Barrier launches, flashes for a while and then stays in the Launcher, but does nothing else.
It worked perfectly when installed, but not the next day and ever since.
Need to remove it (sudo apt purge Barrier did not work) so I can reinstall it.

Did you use apt to install barrier? Or was it the snap version? You can search for it in the software center and remove it from here.

But before you do that, open Barrier on the client. Use the show option in the panel if required and then can you please share the screenshot of its interface?

Client Barrier does not show anything and goes away after a few seconds. I also copied the server Barrier config file to the client with no apparent results.

Barrier is not in my software listings, nor in Synaptic Packages

I found it under installed and removed it

I reinstalled barrier, using snap and --edge, same result.

1 Like

Which Barrier? There are two of them in Snap version. You should use Barrier Maxiberta (as I had mentioned in the article).

Maybe the source can help.

That is the one I used and still no go. I will check Github…