.bashrc alias problem can you help? (SOLVED)

Anybody see what’s wrong with this? I’ve been using some ‘alias’ commands in .bashrc for quite awhile now. I added a new one and it seems to have ‘commented’ out everything after the new one - jud=“sudo updatedb”…

Hi @panhead51,
I think it’s because you have apostrophes instead a quotation marks

alias  jud=“sudo updatedb”
# change to 
alias  jud="sudo updatedb"

Thanks Tech_JA!!
Both look the same (almost). I don’t know how to key the other quote mark. Is it the text editor I’m using???
I copy and pasted your line in and it worked.
I was getting: bash: /home/jim/.bashrc: line 116: unexpected EOF while looking for matching `"’ so, clearly the encoding of one quote isn’t the same as the other.
I’ve tried Abiword and Text Editor for maintaining the .bashrc file…

1 Like

Use a regulr text editor or a code editor. Text editors for office purposes, like LibreOffice, tend to format stuff weirdly and incompatibly.


Any suggestions for which editor to try? Sublime text maybe? I don’t do a lot of coding anymore.
Thanks Tech_JA and Akito!!!

1 Like

About the keys:
In this example, this is an English keyboard, the quote is the upper symbol and the apostrophe is the lower symbol, both in the same key

1 Like

Yes, that’s what I was using on my keyboard. Apparently the text editor I was using, uses different encoding of the quote mark than the system requires in the .bashrc file.
BIG TIME thanks for your help!

You guys nailed it! THANKS FOR ALL OF YOUR HELP!!!

1 Like