Bizarre behaviour - Ubuntu 19.04

Yeah - I know I should update to 19.10 (19.04 EOL in coming January - I will do it before then) - however - I’m loathe to upset my precarious balance between Dropbox restricting me to 3 devices (I’ve got 6 I “need” connected - at least) and “sanity” (I rely on Dropbox at work in my job).

Anyway - my main home laptop, running Ubuntu 19.04 has recently started going “berzerk” - that’s the only way I can descibe it (it’s not happening now!) - I’ll be doing something, e.g. an online quiz in Chromium, an online crossword in Chromium, or watching a “local” video file in VLC - and all of a sudden, it’s like a drunk person is controlling my mouse, the OSK (on screen keyboard) will pop up and off, when it’s there, I’ll see “random” buttons being pressed, weird shit will happen - but I’m pretty sure it’s not some trojan backdoor (nothing suspicious pops “up” if I switch to a virtual terminal e.g. CTRL+ALT+F4 - nothing tries to take over or “drive” things when I’m in a vitual TTY).

Happened this morning, and bizarrest of all - suddenly my desktop was no longer @ CTRL+ALT+F2 (why oh f–king why did Ubuntu or gnome.org move it from virtual terminal 7 in the first place???) - it was now on CTRL+ALT+F4 >:( why?

Driving me crazy… half of me’s thinking it’s hardware related. some relay or whatever in the HCI circuits is getting shorted or something? Then it all comes good again? Like right now?

Anyway - long story short : I’ve got another laptop I can use, and I started using it this morning when “this bastard” went haywire yet again… Tried using that again this arvo (boss knocked us off early via the pub so I’m home @ 4pm xmas eve) and the f–king wifi drops in and out… Had this problem before, tried disabling hardware/software control of wifi hardware… that didn’t work… rebooted - still no wifi… So I’m back on the dodgy bewitched piece of cr@p that spawned this thread!

Shock horror! I might have to resort to using my iPad Pro (2018 12.2 ")! Oh No! Damn! If I had that money to spend again, I’d have bought a proper late model Dell Laptop, instead of trying to make these hand-me-downs behave properly!

Anyway - this b@stard is behaving right now - so I don’t think it’s hardware. I’m sure it’s related somehow to me re-enabling touch support in the BIOS. I quickly disabled it shortly there-after, but I’m sure there’s a “ghost” of touch dependancy in this freakish behaviour…

And no - I’m not going to try Mint or any other Ubuntu derivative - I want to keep this b@stard running “in place”, update it to 19.10, and then 20.04 when it’s released, just so I don’t have to lose another device to Dropbox’s bastardly behaviour of limiting non-financial users to 3 devices… if I was to distro hop again - it would probably be to elementary…

I’d try swapping HDDs between the two Dell laptops - however this b@stard I’m using uses an M2 512 GB SATA card, and the other one (with dodgy wifi) uses an mSATA 256 GB SSD…

1 Like

seems like an instance where a live 19.10 usb should be able to help determine if it is a hardware issue or something to do with that particular install. any enlightening entries in journalctl?

Dan, I’m likewise too cheap to spend money on Dropbox. I’ve expanded my storage by uploading photos–lets you go past 2G for free, but I haven’t figured out a workaround for the three devices issue. MEGA is now where I store the big stuff, photos and music and a very few videos. That relieves some strain on the Dropbox limit. If I’m going to install Dropbox on any system, it’s only for systems I’ll use for a while–my ‘sandbox’ drive gets a new distro every week or so, but never gets Dropbox.

Cordx has a good idea, sticking in a live 19.04 usb to see if the problem recurs. And, whatthehell, format the thing and do a clean install of 19.10. All your important crap is on Dropbox, right? Just remember to sign in to Dropbox and clean up your devices list.

And a glorious Solstice to you all!

2 Likes

I had a long running problem starting with 14.04 and 16.04 where the mouse could move around the screen but I couldnt click on anything. I would have to wait upwards of an hour for whatever was causing the issue to clear up - or just turn off the system, restart and hope it didnt happen again. I reinstalled the os more than once on 14 and at least 4 times with 16 and it kept coming back. I swapped out usb mice for wired mice, wireless keyboard for wired, tried different combinations… it was a pain. At some point a update cleared that issue and I never had it again.

I was posting on several lists trying to get help and people thought I was f’ed up crazy. Whatever. You run into these crazy things.

For what its worth, I ran 19.04 on my thinkpad without issues, some older thinkpads and some hp that I tried it out on and did not have that problem. They also have touch pads. Maybe its with a previous update - esp since it is doing it on two different units.

If you can split your devices into work & play, maybe your cat can get a Dropbox account and keep her stuff on 3 devices, then you keep work stuff on 3 devices.

I’m looking into building a Owncloud server as a better solution.

1 Like

Well here we are Friday, and touch wood, symptoms haven’t recurred since around Tuesday morning…

As for Dropbox? I’m having trouble divorcing myself from it… I’ve been weaning myself of it partiially, by using Resilio Sync (e.g. my most played music, all my shell scripts, ssh connection settings [my ~/.ssh/config is a symlink to one I store in one of my resilio sync “shares”], documents and e-books)… I’ve also started using MegaSync (I sync my whole ~/Dropbox folder to there)… but it’s hard…

I started using Dropbox in the noughties, and have slowly built up / earned 11.5 GB space through referrals and other incentives… from around 2013 to 2017 I actually paid around $11 a month for 1 TB (and I barely used 200 GB), but had to give it up when I was involuntarily out of work - however its since actually gone up in price and gives 2 TB, but I don’t need 2 TB… I just want more than three devices (and approx 256 GB of space)!

These are the devices connected to my Dropbox account :

  1. Windows 10 laptop at work
  2. Ubuntu 19.x laptop at work (it’s my personal equipment, 'cause work won’t give me a second laptop with Linux on it).
  3. Ubuntu 19.x laptop at home
  4. Ubuntu 18.04 desktop at home
  5. iPad 3
  6. iPad Pro 12.2"
  7. Samsung Galaxy Note 12.2" “pro” tablet
  8. Samsung Galaxy Note 3 (smartphone) - off
  9. Google (LG) Nexus 5 (smartphone) - off [battery “blew up”].

Because of those 9 devices - I can’t connect my “new” Nokia 4.2 smartphone…

Sure, I could remove the Note 3 - it’s powered off, and the Nexus 5, the iPad 3… but that would still leave 6 I’d like to keep connected… plus my new main mobile phone handset, which I can’t add…

So I have plenty of incentive to wean myself off Dropbox… unfortunately there are plenty of things to keep me there… I actually use it to share stuff with friends and family… it works “everywhere” (e.g. work block me using Resilio - I’ve cheated and I keep a VPN tunnel connected from home to the office [legit - using work’s hideous Checkpoint VPN product], and hard code IP address of my work Ubuntu machine in my resilio sync “peer list” on my home Ubuntu laptop - for a while I was also taking in to work, daily, and home again, a BananaPi with 256 GB USB drive, to keep home and work “synced” in Resilio).

I’m reluctant to rely on MegaSync, 'cause who knows when work will suddenly start blocking that? Dropbox uses http/https…

I’ve tried / experimented with Owncloud and Nextcloud - for my money Resilio Sync is superior, apart from accessing stuff via the cloud (it was working at work 'cause I used NoIP dynamic DNS to talk to my main home resilio sync repository running in a FreeBSD jail on my FreeNAS - but then work started blocking the TCP/UDP ports Resilio needs).

We have two cats, the female wouldn’t share anything with me, the bitch (only kidding - but she doesn’t like me - doesn’t like male humans in general)… Male cat likes me (loves my beard), but he’s 15 soon, and don’t expect to have him much longer. My dog used to have her own facebook page, but she passed on in late 2012, and I’ve forgotten her password… technically a dog having its own facebook page was against the terms and conditions, but the Zuck’s own dog had its own facebook account!

I’ve tried creating multiple Dropbox accounts in the past, not very successfully (they always seemed to catch on I was trying to scam more space).

Anyway - prompted by this limitation, this morning I’m now doing 95% of my common “workload” that needs some kinda cloud sync, onto Resilio Sync… sync’d my main Resilio shares to my Nokia phone… cooking with gas…

I might actually be able to disconnect my Windows 10 laptop from Dropbox now… the biggest limitation of Windows, is its utterly cr@p implementation of something as simple as a symbolic link…

95% of the stuff I access regularly in Linux, that’s sync’d to some sort of cloud sync service, is done via symlinks…
~/Music
~/Pictures (including screenshots)
~/Documents (including e-books)
~/bin

On Windows, I just have a “frequently accessed” link to my Resilio Sync folder… so feature limited… probably other ways to work, but I can’t be @rsed to figure them out, as I avoid using Windows like I avoid sharing needles with junkes :smiley: (by not injecting narcotics into my bloodstream)…

Update : solved (but not fixed).

I ended up taking the thing (Latitude E7270) apart this morning. I already knew the battery was on its way out (max 30-40 minutes life), but I had no idea just how bad it was!

The battery was swollen on both sides! On later Dell laptops, you can only remove the battery by removing the base plate on the chassis (I much prefer being able to swap out the battery, or pull it out - e.g. when a laptop won’t shutdown or power-off)… anyway - I suspect the swollen battery was making contact with the ribbon cable connecting the touchpad and buttons…

So anyway - I did notice yesterday that it seemed to happen when/after I pressed the left button on the bottom of the touchpad - and didn’t use it again much after that… e.g. I used my iPad this morning to do my morning stuff (i.e. play quizzes and crosswords while drinking coffee and first cigarette of the day out in the patio)…

So - I’ll be ebaying a new battery for it now, poste-haste…

Right now I’m using a Latitude E7440 (Ubuntu 19.10) which I “inherited”, but I’m hesitant to use it, 1. the wifi and bluetooth keep getting disabled (it’s not the button on the side, nor the FN key to disable or go “flight mode”). 2. It’s got a trackpoint (nubbin? or rhymes with Deloris) - but none of the 3 buttons for the trackpoint work (the trackpoint navigates) - and I love trackpoints (I use a Lenovo Thinkpad USB keyboard with Trackpoint at my desk at work, and home), but it’s next to useless if the buttons don’t work - I’m beginning to suspect someone opened it up and physically disconnected the trackpoint buttons (to do : open it up and find out).

Anyway - I’m using it (E7440) with a tiny USB realtek RT5370 wifi dongle - it works, but it’s only 2.4 Ghz and some damnslow mbit rate (e.g. not suitable for watching movie files mounted on an NFS share from my NAS)… eitherway, it’s still better than using an iPad…

1 Like

Update : you wouldn’t read about - but - the Latitude E7440 also has a swollen battery! Doh! The battery on these is removable without taking off the bottom plate - however - this battery is so swollen - I can’t “easily” remove it… Was about to remove all the bottom “stuff” from it to access the ribbon cables connecting the three trackpoint buttons (not necessarily the touchpad buttons - they work) - when I noticed the bulge at the bottom - then was unable to remove the battery… Double Doh!

Damn - and I’m broke after Xmas, so can’t afford to buy any batteries till I get paid next (I get paid monthly and I detest it!).

Edit: cannot get this cr@ppy Checkpoint VPN client to run on the Latitude E7440… got it running on the E7270 running Eoan Ermine (it was installed and running before I updated from Disco to Eoan), my gaming desktop running Bionic Beaver, my laptop at work running Disco Dingo… but cannot get it to connect using this Eoan Ermine (just installed it this morning with 32 bit pre-requisites)… I REALLY hate this product… sheez I wish my employer would use something more open from Cisco, of which there are at least three open source CLI clients for connectivity!

1 Like