Black screen when trying to login

I upgraded my ubuntu to 20.04 3 data ago and all was fine till today.
I was trying to open ubuntu and after hitting at selection prompt, it tried to load ubuntu but ended with black screen. I seen a post on similar issue by adding nomodeset at linux line after E to edit the grub but it did not work for me. I am stuck and urgent hint will be really appreciated?

fipoucat

1 Like

Welcome @fipoucat to It’s Floss Community. I use Linux Minx and never seen a black screen during logon. But then again I am kind of new to Linux. Things that come to mind.

  1. What did you change last and can you boot an USB live stick and back out the change?
  2. Restore your system to you last good working backup. Maybe Timeshift?
  3. Ubuntu is so quick & easy to install that you could easily spend more time trying to fix this black screen problem then it would be to just re-install it.

PS: This is probably not the answer you were looking for.

Did you make some changes to settings lately? Maybe your desktop somehow got corrupted.

One way to handle is to reinstall GNOME desktop.

On the login screen, use Ctrl+Alt+F1 or Ctrl+Alt+f2, Ctrl+Alt+f5 or a combination of Fn key like this.

One of these shortcuts will take you to terminal screen. You can login using your username and password.

And then reinstall the gnome desktop using this command:

sudo apt install --reinstall ubuntu-gnome-desktop

1 Like

I followed the instructions, login with user and passwd and then use the reinstall command:
sudo apt install --reinstall ubuntu-gnome-desktop

The system reinstalled the packages with success, but when I reboot, got again the same black screen.

Should I do something else?

Did you use live media to install Ubuntu? If not, then you might consider.

No, I upgrade from 18.04 to 20.04 and all was fine. The last time I used it all was OK I did not change anything and shutdown properly. I was then surprised with this black screen!

There is a bug open for this issue with Nvidia:

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1870779

1 Like

I am running Ubuntu 20.04, it installs and works with the live cd, even with a Nvidia GPU.

1 Like

In my case it is not a fresh install, it is an upgrade from 18.04 with many programs in it already.
I hope the bug will be fix in a very short term?

1 Like

I understand. Did you by any chance do a Timeshift bkup?

@fipoucat, do you have a Dell pc? Found a possible fix doing a search. In BIOS turn PPT security off (or disable). I will not re-type the details, but you can find it here;

Good Luck

I am using an HP pavillon?

Did you read the fix? You could always try the solution and if it does not work, nothing lost. :smiley:

1 Like

PTT is not available on HP Desktop from what I seen on my computer in BIOS.

Hi @fipoucat . I was having similar problem with ubuntu 20.04. I tried nomodeset and PPT settings but they didn’t work. However, then I updated my BIOS to the latest version(I am currently using Dell Vostro 3580). And now it is working perfectly.
(I found ubuntu 20.04 somewhat slower. So now, I changed the OS to fedora 32 and it is great.)

2 Likes

Thank you, maybe my problem is due to the fact that I upgraded my 18.04 which was working fine. In the computer I installed a few models not easy to install sometime stakes time. That’s why I whish ubuntu Team will fix this in a short time as it looks many people are having similar issue. I after the next update it is not solve then I’ll try to go back to 18.04 or install mint or fedora.

1 Like

I had this same problem with Ubuntu 20.04 using the NVidia proprietary drivers (both 440 and 450) for my Geforce RTX 2070. The problem was with the experimental feature of fractional display scaling that I enabled in the Display configuration settings. Apparently, the NVidia drivers do not play well with these settings (yet) and a bug has been filed for it:

There are several ways to remedy this:

  • Check your ~/.config/monitor.xml settings and change any value occurring between <Scale> tags back to 1. Then save and reboot. This didn’t work for me though although I have seen others report success.
  • Reset the fractional scaling setting to off by executing
gsettings reset org.gnome.mutter experimental-features

Reboot and hopefully this will bring back your screen (like it did for me).

It’s too bad that this doesn’t work well yet. I had written a basic xrandr script on 18.04 to get the scaling on my 2 displays with each a different resolution right, and that worked well, but I was happy to see there finally was GUI support for this feature in 20.04. Hopefully they manage to fix this soon.

1 Like