Boot Time Extremely High!

Hello there, since the past 1 week my boot time has become ridiculously high.


Can someone please suggest if this is a hardware issue or software-related? I couldn’t find anything regarding this on the internet.

Edit 1
had gone through those and tried still couldn’t reduce the time.

Kernel: 5.4.0-72-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4.0-72-generic
root=UUID=b53d0795-4089-445e-af66-cd9e1ab02ce8 ro noveau.modeset=0 quiet
splash vt.handoff=7
Desktop: Gnome 3.36.7 wm: gnome-shell dm: GDM3 3.36.3
Distro: Ubuntu 20.04.2 LTS (Focal Fossa)
Type: Laptop System: LENOVO product: 80SV v: Lenovo ideapad 510-15IKB
serial: Chassis: type: 10 v: Lenovo ideapad 510-15IKB
Mobo: LENOVO model: Torronto 5C1 v: SDK0J40679 WIN serial:
UEFI: LENOVO v: 3JCN24WW date: 12/29/2016
ID-1: BAT0 charge: 14.1 Wh condition: 22.5/39.0 Wh (58%) volts: 7.2/7.7
model: CPT-COS 1 L15C2PB7 type: Li-poly serial:
status: Discharging
Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: DE
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 21599
Speed: 600 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 600 2: 598
3: 599 4: 573
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:5916
Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Lenovo driver: nvidia
v: 450.119.03 bus ID: 03:00.0 chip ID: 10de:134d
Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa compositor: gnome-shell
resolution: 1366x768~60Hz
OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 450.119.03
direct render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
Sound Server: ALSA v: k5.4.0-72-generic
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 4000 bus ID: 01:00.0
chip ID: 10ec:8168
IF: enp1s0 state: down mac:
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel port: 4000 bus ID: 02:00.0
chip ID: 168c:0042
IF: wlp2s0 state: up mac:
Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4
chip ID: 0cf3:e500
IF-ID-1: docker0 state: down mac:
IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac:
IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac:
Local Storage: total: 931.51 GiB used: 334.24 GiB (35.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: 6E scheme: GPT
ID-1: / raw size: 439.44 GiB size: 431.54 GiB (98.20%)
used: 75.98 GiB (17.6%) fs: ext4 dev: /dev/sda2
System Temperatures: cpu: 49.5 C mobo: N/A gpu: nvidia temp: 51 C
Fan Speeds (RPM): N/A
Processes: 331 Uptime: 9h 08m Memory: 7.68 GiB used: 3.55 GiB (46.3%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 7/9
Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

I did an update and upgrade on my system. Installed bleachbit and VMware (for windows related work) in the past week.

Please check out all the links first.

After you have done that, please add the following command’s output to your post:

inxi -Fxz

Do you remember, what changed a week ago? Did you upgrade anything? Install new software? Change settings/configuration?

1 Like

I generally find with Laptops, that they boot quicker plugged in, so I take out the battery and rely on power only. If of course you’re able to find a power outlet? Every OS I have ever tried on a laptop booting from battery slows down boot time tremendously. I sometimes take my Laptop to work with me, as I work nights and am able to use power outlet.

I see you have a Nvidia card, that can slow down boot time too, as it’s booting it’s finding the default display, especially if you have the new Nvidia Driver for Laptops, that let you choose which display driver you want to use. Whether it’s Intel or AMD or Nvidia display. Also is there any not needed programs starting up at boot, that the boot loader has to read and load up? So many factors come into play when booting a Laptop from battery. They are even slower in Windows to boot.

The problem is most likely BIOS setup. I had the same problem with my machine. Went through the BIOS line by line and made sure that it was set up for the hardware in the system properly. Now it boots up in less than 15 seconds and shuts down in less than 10 seconds. Windows machines don’t even finish POST in that time! Good luck.

I did a fresh install and the firmware time now is below 10 sec. Still the userspace time is quite high (around 1 and half minutes).

Startup finished in 4.840s (firmware) + 5.714s (loader) + 4.764s (kernel) + 1min 41.076s (userspace) = 1min 56.396s reached after 1min 39.893s in userspace

systemd-analyze blame
1min 10.380s plymouth-quit-wait.service                                        
     54.137s mysql.service                                                     
     45.060s docker.service                                                    
     38.583s udisks2.service                                                  
     28.261s networkd-dispatcher.service                                       
     20.606s NetworkManager-wait-online.service                                
     19.959s ModemManager.service                                              
     13.475s dev-sda2.device                                                   
     12.600s snapd.service                                                     
     11.741s vmware-USBArbitrator.service                                      
     11.521s vmware.service                                                    
     10.738s nmbd.service                                                      
     10.044s accounts-daemon.service                                           
      8.836s polkit.service                                                    
      8.632s NetworkManager.service                                            
      8.505s avahi-daemon.service                                              
      8.503s bluetooth.service                                                 
      8.014s switcheroo-control.service                                        
      8.009s thermald.service                                                  
      8.003s wpa_supplicant.service                                            
      7.982s systemd-logind.service                                            
      7.096s smbd.service                                                      
      7.085s dev-loop22.device      

I don’t why but certain services have time > 20 sec. Is there any specific reason for this?


If that doesn’t work, refer to the following:

My recommendation for what you should remove from your system:

1 Like

Sometimes, a slow boot issue can be caused by a hardware conflict. I f you have recently added new hardware, I would check that.

Can happen after cloning…Here is a solution if none of the others work:

wow! glad to hear this :wink: , The boot time, It is because of changed UUIDs , i.e, The new UUIDs and Old ones of your important partitions (home,Swap) has chamged. To correct this, please follow the instructions given here with suitable changes : If you find any problem, please comment it. – Severus Tux Mar 4 '16 at 13:52