Booting Windows and Linux


This is the snip I want. As one can see W10 is on Disk 0, Linux Mint is on Disk 1, Data is on Disk 2,
Gentoo Linux is on Disk 3, Grub Rescue is on D: CD-CDROM.
Problem is getting Disk 0, Disk 1, Disk 3 to boot separately. I know it can be done by installing
grub to the Disk 0 MBR, but that will not be done.
This a snip of EasyBCD, which I use for boot entry’s of Mint and Gentoo. This works fine but grub
will default to the Mint entry, unless one of the Linux drives is disconnected.
But I can use the CD-ROM and the Grub Rescue and boot which ever OS I want.
So what am I missing? Is their some way to tell grub which Linux drive to boot?

So, in summary, you want to change the OS which is selected/booted by default through GRUB?

@Akito
What I really want is the OS I select with EasyBCD to boot, but when either Linux entry
is selected, grub will default to Linux Mint. I can change the order of the Linux drives
simply by switching the order on the MB. I do not remember grub legacy working in
this way.I am wondering if I could edit the Bootloader Path: \NST\AutoNeoGrub1.mbr.

EasyBCD 2
I do believe I have solved the issue!!!
This all relates back to the incompatible issue with Debian based and Arch based distros.
The fix was to use EasyBCD installed in W10 and set the W10 Disc0 as default boot.
Use the Rescatux CD to boot into Linux Mint and set the " GRUB_DISABLE_OS_PROBER= true "
in the " sudo nano /etc/default/grub " save and exit and run " sudo update-grub "
Use Rescatux to boot into Gentoo and run " emerge sys-boot/os-prober " and
run sudo /etc/default/grub and set grub " GRUB_DISABLE_OS_PROBER=false " save and exit and
run " grub-mkconfig -o /boot/grub/grub.cfg " it should find all boot entries.
Remove the Rescatux CD and boot into Windows, use EasyBCD to enter the Gentoo Linux
boot entry. Reboot and their should be two entries to chose from, select Gentoo Linux and it will
then boot into the Grub Menuu that will list all boot entries.
You can, if you want to set the Disc3 as the default in MB bios, but I for one will leave Disc0 as default.
Issue solved.

1 Like

Yep.
Keep in mind you will need to keep the set up EXACTLY the way you have it in terms of Windows. The others are all interchangeable for the most part.
Windows DEMANDS boot sector 0 disk 0.

1 Like

@7blade
Yes, I know that, but that is or was not the problem. Explain to me when grub is configured using
" grub-mkconfig -o /boot/grub/grub.cfg " is any different from using " sudo update-grub ". The
whole issue boils down to a difference between the two. The Gentoo grub entry will boot Mint
and Windows with no problem, but the Mint grub will only boot Mint and Windows.
Their is something different between the grub entries, but I am failing to find the root cause.

Through my own ignorance, I do believe I have found the
mistake I have been making with grub and the booting of
Gentoo and any other Linux distro.

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to kernel

#GRUB_DISABLE_LINUX_UUID=true
This line in grub has been the whole issue. I use /dev/xxx
in etc/fstab, and I assumed one needed to uncomment the
GRUB_DISABLE_LINUX_UUID=true, but that is a no no.
One needs to leave the line #commented so grub can
pass root=UUID=xxx to the kernel. Live and learn!!!

2 Likes