BorgWeb fails to launch

Hi,

I recently installed and configured my Centos7 box with BorgBackup software.
I managed to successfully install the command line version of it. This means I managed to initialize the remote repository with the “borg init” command and then run a simple backup with “borg create”. I managed to see the created backup with “borg list”.

However, I had some problems bringing up the web interface for Borg, which is borgweb.
I successfully followed the steps for installation (https://borgweb.readthedocs.io/en/stable/installation.html) and reached this output :

[root@centos-7 ~]# ./borg-env/bin/borgweb
 * Serving Flask app "borgweb.app" (lazy loading)
 * Environment: production
   WARNING: This is a development server. Do not use it in a production deployment.
   Use a production WSGI server instead.
 * Debug mode: off
 * Running on http://127.0.0.1:5000/ (Press CTRL+C to quit)

However, when I try to run the page from the browser, I get an error (image attached).
Why is this, and how do I resolve the problem ?

Best Regards,
anaigini

Finally someone who knows his stuff.

Run

netstat -tlnp | grep borg

and post the output.

Try chromium, just to be sure about excluding the browser as a source of erroneous behaviour.

Since this is Centos 7, the command is “ss -tulnp” :slight_smile:

[root@centos-7 ~]# ss -tulnp | grep borg
tcp    LISTEN     0      128    127.0.0.1:5000                  *:*                   users:(("borgweb",pid=12033,fd=3))
[root@centos-7 ~]#

I hoped that at least such an extremely basic command was equivalent in naming. Apparently I assumed that unsuccessfully.

Did you try to run in Chromium? Preferably in an incognito window.

The output attached

One more thing I forgot to mention, the 127.0.0.1:5000 is the server that runs the borg. The ip of this server from my laptop (I access it using putty) is 192.168.121.74.

So I am not sure how to access it from the browser? http://127.0.0.1:5000 or 192.168.121.74:5000?

I even tried to telnet from my desktop to the server ip using port 5000 :

[Owner.L12-IT-AIGINI] ➤ telnet 192.168.121.74 5000
Trying 192.168.121.74...
telnet: Unable to connect to remote host: Connection refused

[Owner.L12-IT-AIGINI] ➤ telnet 127.0.0.1 5000
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

Are there any firewall settings that I have turn off? On Windows? Or on the network level?

You should’ve mentioned that crucial detail in the first place. It’s like you’re trying to talk to Margaret (192.168.121.74) but actually you’re talking to yourself (127.0.0.1). The latter IP is always your the machine you start the request from, not a different one.

If you can’t access

because of

then there is probably a firewall blocking access on the server. Now if the server uses iptables and does not have an easy interface to iptables like e.g ufw on Debian, then have fun with setting up iptables. That is exactly the reason I would recommend an OS for a cent or RHEL only to people I hate or know these OSes perfectly, anyway.

Just look up how to deal with it on an OS worth a cent. If you would use Debian, e. g. then you would be already connected to your Web UI, right now, without any fiddling. :laughing:

If it’s a firewall blocking on CentOS/RHEL/Orrible :

systemctl stop iptables

And if that fixes your problem then :

chkconfig iptables off

Will stop it loading…

It could also be selinux - set it to disabled in /etc/sysconfig/selinux and “targeted”… sometimes it works “on the fly” but usually requires a reboot on CentOS/RHEL/Orrible…

I guess it’s kinda “wrong” from a security standpoint, but I’ve nearly always disabled iptables, iptables6 and selinux on O(riible)EL and its ilk…

N.B.: I actually don’t hate Oracle Enterprise Linux that much, it’s okay for a server O/S - but I hate the company Oracle, and especially hate having to deal with them, hence “Orrible”.

I agree with Akito that the RPM based distros are not up to much on the desktop…

2 Likes

I already presumed you were able to help, considering your experience.

no idea what this “borg” thing is…

Recently ran into issues with FreeRadius on CentOS 6… I mean blocking everything you ever might want to run, and the only option to disable selinux? What’s the point of it? “selinux” I mean… who’s got time to tweak these things? Fix a problem and move onto the next issue and bugger security…

It was doing my head in… but disabling selinux fixed it… after a reboot…

The best backup software I have seen in my entire life. Tell me about a backup software and I will tell you how Borg Backup is just plain better.

People paid for it or saving the world with a little data disk.