Bucklespring or any other clicking noise emulator

Hi all, :wave:

does anyone have some practical experience with bucklespring :question:

Here´s the background to my question:

Back in 2020 I wanted to insert a clicking noise whenever any keyboard key was hit. Here´s what I had in mind back then:

I was looking for a program that made a clicking sound every time you pressed a key on the keyboard.
I used to use an old mechanical typewriter in the past, and now I somewhat miss that audible feedback.

During my research I came across “bucklespring”: Make Your Keyboard Sound Like The Old Buckle Spring Keyboards In Linux .

You can actually install it not only as a snap package but with apt as well:

rosika@rosika-Lenovo-H520e ~>  buckle
Command 'buckle' not found, but can be installed with:
sudo apt install bucklespring

As a test, back then I installed it in a VM (BodhiLinux). However I was not entirely happy with the result, as the sound reproduced had a lag of around 1/4 to 1/2 second, which was rather irritating. :slightly_frowning_face:

Here I also found the following hint:

With “xset” you should be able to produce a clicking sound in the terminal:

xset c 100 c on

This however didn´t work at all.

So back to bucklespring.

After that I also installed bucklespring on my productive system.
Interestingly, the same phenomenon with the lag could be seen here too. It seems the VM wasn´t to blame for that. :thinking:

As I said, these experiments were carried out some years ago when I was still using Lubuntu. Now I´m on Linux Lite and haven´t bothered with this topic so far.

Before trying anything else I´d like to know if anyone of you has had any experience with bucklespring or any other clicking sound programme.

One thing to bear in mind: the respective programme/process shouldn´t be too hard on RAM or CPU. :wink:

Thanks a lot in advance.

Many greetings from Rosika :slightly_smiling_face:


Hi @Rosika ,
There may be something in the accessibility options


Seems to be a snap application in the Ubuntu/Debian repository. Maybe try it in a VM (although it likely will lag).


Hi, @Rosika

I remembered an app I used to use that made the typewriter sounds. It was FocusWriter. But I did have some notes from a long time ago that might be helpful.

There are some implementations to play a sound for every keypress, one of them is “keypress” on Github.com, made by Github user “chrelad”. It’s a fork of linux-typewriter.

And I never checked out: GitHub - aitjcize/Qwertickle: Typewriter sound effect for your keyboard on Linux

Hope you find something.



Performing a search, I found this.

“I can find the following packages if I search for “keyboard sound” with my distro’s package manager:”


Here’s the website links I can see in the details for those packages:


Hi all, :wave:

thanks so much for your replies. :heart:

@nevj :

Thanks for the suggestion, Neville.
But I fear I don´t quite understand. What do you mean? How can I look for it?

@berninghausen :

It seems it can be installed regularly as well (see my post #1). No snap needed, I hope.

Also: Ubuntu – Package Search Results – bucklespring does indeed list it. At present however the site seems to be unavailable.

@Sheila_Flanagan :

Thanks a lot for your suggestions, Sheila.

I found focuswriter here:

Seems to be a complete word processor. Might be a bit over the top for my purposes of just getting some clicking sounds.
However, I´ll take a closer look at it.

Thanks also for the other suggestions. :heart:

@easyt50 :

How kind of you for doing some research and coming up with quite a collection of references, dear Howard. Thank you very much. :heart:

Seems I´ll have to do quite some preliminary reading before getting on with the subject. But that´s a good thing. :wink:

Thank you again to all of you.

Many greetings from Rosika :slightly_smiling_face:

1 Like

Hi Rosika,
Most distros have a menu item called Accessibility… it is for people who struggle with access and want large fonts and other things.
I thought there might be a keyboard click item there.
Have not had time to check, sorry.

1 Like

Hi Neville, :wave:

Ah, I see what you mean. Thanks for the suggestion.

Yes, there´s soemthing like that in Linux Lite, too.
It´s called “Barrierefreiheit” in the German language version.

There are settings for the mouse and keyboard in it, but no clicking sounds. :neutral_face:
Available keyboard settings are:

  • keys snapping into place
  • decelerated keys
  • keys springing back

Interesting. I never knew such settings were available. :wink:

Seems I have to look for 3rd party tools after all.
Never mind. @Sheila_Flanagan and @easyt50 have provided me with a collection of possibilities.

Thanks and cheers from Rosika :slightly_smiling_face:


Hi again, :wave:

in the meantime I gave bucklespring another try.
I hadn´t installed it on Linux Lite before. My experience regarding the lag dated back to my Lubuntu days.

To my surprise it seems to work quite well now. :smiley:
No discernible lag so far. And it doesn´t seem to be all too heavy on the CPU either.

One thing though:

The volume of the clicking sounds seems a bit low. In actual fact the sounds my keyboard produces are a bit louder.

I haven´t found an option to tweak the volume yet.

These are the options available:

buckle -h
bucklespring version 1.4.0
usage: buckle [options]


  -d DEVICE use OpenAL audio device DEVICE
  -f        use a fallback sound for unknown keys
  -g GAIN   set playback gain [0..100]
  -m CODE   use CODE as mute key (default 0x46 for scroll lock)
  -h        show help
  -l        list available openAL audio devices
  -p PATH   load .wav files from directory PATH
  -s WIDTH  set stereo width [0..100]
  -v        increase verbosity / debugging

I thought the -g option would fit the bill but it doesn´t.
If I set it to 100 it´s equal to the default value.

Of course I could increase the volume of my system altogether but this would be too loud for some other applications, like the Big Ben chimes triggered by cron
… or for the sound of incoming e-mails etc.

Does anyone know of a way to tweak the volume of a single process, in this case of bucklespring, without affecting the ouptut volume of anything else :question:

Perhaps it cannot be done… :thinking:

Thanks and many greetings from Rosika :slightly_smiling_face:

Hi Rosika,
I think you have to use the sound system… ie tweak the pulseaudio volume control
Even a simple click requires the sound card and its software.

I see, you want the overall sound untouched?
Well does pulseaudio not have control over inputs? Tweak the input, not the output.

1 Like

Hi Neville, :wave:

thanks a lot for the confirmation.
That´s what I thought as well.

Never mind. At least I got it running. :wink:

Whenever I feel the urge to use bucklespring for an extended period of time I may want to switch off the Big Ben chimes etc. temporarily…
… and increase the system volume.

Many greetings from Rosika :slightly_smiling_face:

1 Like

@nevj and all:

Hi again, :wave:

I actually found a way of turning up the volume of the bucklespring process without affecting any other sound output streams:

The pavucontrol GUI provides a simple way of achieving the task:

For this I had to…

  • click on the loudspeaker symbol in the taskbar
  • click on the sound mixer entry

This led me to the settings GUI: see screenshot above.

Here I could tweak the volume of just buckle.
As you can see I set it to 136%, which seems the right volume for me.

Seems it can be done after all. :wink:

Many greetings from Rosika :slightly_smiling_face: