Caja crashes after unmounting external USB drive

Am using Ubuntu 18.04 with Mate DE. The file manager Caja v 1.20.2 crashes (or terminates) every time an external USB disk is “Safely Removed” (unmounted) by right-clicking on the drive entry in the side panel of Caja.

A search on the web revealed that this was a reported bug #1787242 on launchpad in 2018. [https://bugs.launchpad.net/ubuntu/+source/caja/+bug/1787242]

The bug log says that this was fixed in Ubuntu Mate 19.04 in May 2019 in version 1.20.3. So I am concluding that the version 1.20.2 that I am using (because that is what is there in the Ubuntu 18.04 repository) still has this problem.

Looking to confirm my understanding as above, and if there is a way by which I could get Caja V 1.20.3 under Ubuntu 18.04.

I have found a website which has all the past and latest Deb packages for different OSES. Scroll down to Ubuntu and you’ll see that 19.04 isn’t mentioned, so isn’t Caja version 1.20.3. https://repology.org/project/caja/versions
You could ask on Ubuntu-Mate forums. I know that Martin Wimpress would be interested if this has not come up in their forums before? He may have the answer for you. Also what hardware are you using? That can have a factor to this unmount problem too. Here is a link to Ubuntu Mate Community Forums
https://ubuntu-mate.community/
I’m sorry I could not be of much more help.

Thank you for your suggestions. I am using a Lenovo Ideapad.

My main concern was, and is, whether the copying to the external device is being disrupted by this sudden termination that appears very much like a crash. So far it hasn’t corrupted any device, but the doubt remains. And upgrading OS for this seems too much. So perhaps I should look around for a more robust file manager for these tasks. Nemo, Nautilus appear to be candidates but if they share the affected code then they may not be.

Thanks again.

I’d install Nemo, as I’m using Nemo in XFCE and have no problems with it. Don’t uninstall Caja though as Mate relies on Caja for a lot of things. I’m going to install Ubuntu Mate 18.04 in a virtual machine and install Nemo I’ll report back my findings later on tonight.

I tried out Nemo in Ubuntu Mate and I must say that the Mate don’t half take over. After you have installed Nemo go to preferred Apps in the menu, instead of Caja pick out files that’s in the drop down. Next open a terminal and these commands will make it default for certain and you’ll be able to open Nemo in your Terminal too. This first command is to open Terminal with Nemo.

gsettings set org.cinnamon.desktop.default-applications.terminal exec mate-terminal
This next command is for desktop icons, so you have full control with right click on your desktop.

gsettings set org.gnome.desktop.background show-desktop-icons false

And finally this command, which makes Nemo the default file manager.

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

These commands I always put into every OS I run or try out, as I’m still hopping at the moment. Though have been enjoying Mint 20 XFCE so will probably stay with it.

If you’re like me and fed up with the green in Ubuntu Mate here is a link to my Dropbox with different colored mainly blue I’m afraid themes, plus the deb file is Ambiant-Blue-Icon set. They were originally for 16.04 but they work in 18.04. I hope this helps you out. Link to themes https://tinyurl.com/y3swocgl
These themes I made from the original, as for me Ubuntu Mate is way to green, the only one I did not make is the icon theme, as someone had really spent a lot of time in GIMP to get them right.

Thank you again. Appreciate the detailed help.

I tried Nemo 4.2.3 and Thunar 1.6.15 without changing anything else in the system. Nemo too exhibited the symptom, although less frequently than Caja. But Thunar was absolutely fine!! And Thunar also emitted notifications for “…disk write in progress…” etc. That is one more reason I need to study Thunar documentation, which I will do. Will report back after a few days.

I’m just wondering if it might be wise to move to Linux Mint Mate? Why is because it is lighter in design. Don’t get me wrong Ubuntu Mate is very good, but in my opinion Ubuntu Mate has become bloated over the years. When I first used it in 16.04 it wasn’t as bloated, it was snappy and light. Also as you are using a Lenovo Idea Pad I would consider going to Mint. I have had no problems with mint in all of their desktop environments, I have XFCE version on my Lenovo Yoga 500 and it flies, but also I upgraded the ram from 4GB to it’s max of 8GB, plus a 500GB SSD drive too. Look forward to reading your report with Thunar.

Thunar or Caja… Last few days experience-
Thunar is still proving to be a better option in this particular aspect, however I did notice a few occasions when it too exited suddenly when asked to eject/Safe removal etc.

I’m wondering if you have any read errors on your main hard drive? I would go with a fresh install altogether, sometimes for some reason little things like what you’re experiencing just need a fresh install from scratch, keep an eye on the installation to see if there are any installation errors like USB bus for instance. I had a weird glitch once with USB drives logging me out of my session. I done a complete reinstall and it fixed it.