Calibre not working Ubuntu20.04LTS

Hi, I used to use Calibre now and then but, now I wanted to use it, I clicked the icon nothing happened. I opened a terminal and typed calibre and I got this
okk@oyo:/stack/Downloads$ calibre
Traceback (most recent call last):
File “/usr/bin/calibre”, line 20, in
File “/usr/lib/calibre/calibre/”, line 73, in calibre
File “/usr/lib/calibre/calibre/gui2/”, line 543, in main
listener = create_listener()
File “/usr/lib/calibre/calibre/gui2/”, line 514, in create_listener
return Listener(address=gui_socket_address())
File “/usr/lib/calibre/calibre/utils/ipc/”, line 110, in init
AttributeError: ‘NoneType’ object has no attribute ‘cancel’

I reinstalled it still nothing worked. What should I do?

Many thanks for the help.

Actually, I can reproduce that error.
Please remove the installed Calibre from your system and reinstall it directly from the Calibre website:

sudo -v && wget -nv -O- | sudo sh /dev/stdin
1 Like

I concur with Mina’s contribution - I run calibre on 4 Ubuntu 20.04 machines installed by that method @Mina suggests…

I use it to manage my e-book collection on my Kobo e-reader, all instances of Calibre use the same database stored on cloud storage…

It does annoy me how often it nags me to update / upgrade though, but it does the trick…

Calibre is truly a great program. However, if you just want to export an own text as eBook, there’s also a very cool LibreOffice extension to do so:


Thanks, I did it and it works. I tried to thank but all my e-mails were bounced. Now I find a way to express my thanks.

1 Like