Cannot open "Appearance" in Ubuntu Mate 18.04

I know I had been able to set the wallpaper options in Mate before. However, when I tried to open it, nothing happened. I tried rt-click on the desktop, Change Desktop Background; Control Panel, Look’n’Feel, Appearance; and Menu, Preferences, Appearance. I also tried all these three after a fresh reboot.
Is there a CLI to open it?
Is this a Windows Manager issue? I am using marco.

which version of ubuntu mate are you using? 18.? or 19.? and what happens when you right click on the desktop and choose change background?

It is 18.04, and the right-click method worked before. The issue is that something has happened (maybe a bug in an upgrade??) that has made something that worked at first no longer function.

Specifically, what happens in all three methods is that I highlight, enter (or double-click) and nothing happens.

i also wasn’t clear about what you meant by windows manager issue. what is marco?

any chance you have a backup that you can roll back to? i just tried the right-click on the background in a live session and it worked.

Under Preferences, Windows, it offers you the choice of a windows manager. THe default they offered was something called Marco. More than that, I cannot tell you.

1 Like

mubuntu has a log viewer in system tools. the first one i would check out would be Xorg. then i would look at syslog to see if there might be any indication of what is going on.

Ay, the plot thickens!
THe “system tools” window in Control Panel did not open.

So I opened the control panel from the command line like this:

cliff@cliff-desktop:~$ mate-control-center

** (mate-control-center:12479): WARNING **: 08:18:07.692:
error raised: [load_xbel_store: couldn’t load bookmark file [NULL]

Then I clicked on the Appearances icon, to see this in the Terminal:

mate-appearance-properties: error while loading shared libraries: cannot open shared object file: No such file or directory

In Synaptic, I tried to see if I could get more information on unmet dependencies, but it all checked out as OK.

All I can think of is uninstalling, then reinstalling the control panel. But for such a trifling issue, this seems unnecessarily risky.

1 Like

I don’t know if this will help, but have you tried, in synatic to see if there are any broken packages? If there are you can repair them from there. You probably have done so but it is a thought


Was just going to suggest trying to run a command to fix any broken packages. Dandy beat me to it. :wink:


Synaptic has the option to mark for reinstallation. Is it a good idea to do that with mate-control-center?

That might do the trick. Do you have a backup of your system you could roll back to? Just in case it doesn’t work out.

1 Like

Nope. I reinstalled, hunted for dependencies, and nothing is different. Which log and log entries should I look for?

did you check for broken packages in general as it might not be mate-control-center itself that has the issue? in the synaptic menu bar there is an edit option. near the bottom of that list is fix broken packages.

Repeatedly. Both with synaptic and command line

were you able to get into the log viewer? if so, i would check xorg and syslog, but there is a lot of stuff there to sift through. my go to for troubleshooting is still dmesg -H --level,err followed by --level,warn.

i found this page from the mate community that might be of some help:

Cliff don’t know if this will help at all :

there should also be a hidden file in your /home/user directory called .xsession-errors that might have some info.

That file is not there in Ubuntu Mate, but it is there is Manjaro Mate. Hmm.

Meanwhile, in /.local/shared, I found xorg.0.log which seems to be filled mostly with graphics card information.

I think I may have found some clues, but it is too late to work on it now. In brief, I think those files that the log says cannot be found are in a different location. I can try working on it tomorrow.

my fresh install of mubuntu 18.04.2 has that file.