Canon laserjet under Linux Mint

I have a dual booting desktop with Win7 and Linux MInt 19.3 and a Canon iSensys LBP6200d USB printer. The printer has worked for years under Win7 (vintage 2012) but is proving to be a problem under LM. When any printing has been achieved it has not used the duplexing facility. The recommended capt driver version 2.71 has been installed without effect. Has anyone found the trick to get this or similar Canon printers to work? Any advice would be appreciated.
My Canon Pixma MG680 inkjet with a wireless connection works well with LM including duplexing.

I use TurboPrint in my Ubuntu 20.04 from which solved a lot of problems with earlier versions of Ubuntu so I stick with it.

1 Like

there are some options to try and figure out and use a different driver using lpadmin. one way to see some more settings is to try going to http://localhost:631/ in a web browser.


This is not going to help you … just a comment.

I had a similar problem with the same make and model.
I called the tech desk at cannon
They offered several suggestions for Windows systems
Each time I said I have Linux not Windows they said … but you must have this, your screen must say, but it’s not the same…

They did offer a discount on a new printer but could not confirm it would work under Linux!

Cannon make great cameras, not bad photocopiers, and wonderful door stops !

Sorry no help