Can't boot from linux mint usb

I have created a linux mint usb using How To Dual Boot Linux Mint And Windows 10 [Beginner's Guide]

Used UUI to create bootable usb and things looked good. Opened BiOS on my laptop and it recognized the bootable linux mint usb which I made the first boot priority and saved.

Machine still booted to windows.

Went back to BiOS and confirmed that the boot priority had the USB drive first.
Still no joy.

Reformatted USB using RUFUS tool with same distro
Repeated above steps.
Still boots to Windows regardless, even if I interrupt restart (ESC, separate from F2 for BiOS screen) and try to force boot from usb.

Windows machine is a vanilla 10 with all updates.

Linux and Foss noob. Hope this is OK.

1 Like

Hello Rags welcome to the forum.
Make sure secure boot is switched off in BIOS, as it’s that, that will boot Windows up every time.
Also could you please post the make and model of your Laptop? As this will give us a better idea of what you’re running.
Many Thanks.


Hi Rags,

Your problem interested me to I looked around on the net and found this suggestion:

26Down vote

You need to enable booting from non-EFI devices. This option can be found in most BIOSs called the Compatibility Support Module or CSM. This option is sometimes hidden until you disable Secure Boot. I’ve also seen it hidden until Fast Boot is disabled. Once you enable the CSM module and set it to boot EFI + Legacy boot devices you shouldn’t have any trouble booting your USB device.

I would like to give credit to the poster but I have no idea who wrote it. Perhaps it will help you solve it.

Good luck!


Thanks for the welcome and the advice.

Unfortunately, I have not been able to make much progress. The model number is Asus UX31E.
I was able to find someone who could disable ‘safe boot’ on an Asus UX31A, closest to mine I could find. In that case, the BiOS menu has a setting on the Security Page labeled ‘Secure Boot Control’


On the same screen on my computer I find everything else identical except that bottom menu line is called ‘I/O Security’ the submenu for I/O security has three options, ‘Wireless Network Interface’ 'HD audio interface (both showing ‘unlocked’ and clearly irrelevant) and USB interface security. That submenu contains a usb interface option which is set to ‘unlocked’ and a warning that if locked, all usb devices will be disabled, so no joy there.

I"m beginning to think that my efforts to dip my toes into linux with a dual boot machine is fruitless and I should just wipe the thing and install linux but, of course, who knows how that will go with this issue unresolved?

Thanks again, folks…

Hi Rags,

just a quick question…perhaps burning the .iso to s cd and then booting from the ce drive is an alternative? Even if you want to ditch windows completely you still need to find a way to boot with Linux.

Above link will show you the popularity of the different available distros with links to download the .iso

1 Like

Sadly, no CD drive on the machine. I have a usb cd player, but that gets us back to the same problem.

added BiOS admin password and logged in under it to see if that would help. No change to any boot options.

found the following which refers to the legacy BiOS screen on the UX31e:
however it too does not correspond to my system and all of the safe/fast boot options are unavailable.

One more piece. I was able to flash a new BiOS (from 210 to 214, the latest on the website). Also had no effect on BiOS settings available.