Can't get "Tablet-Screen" of Asus Taichi21 to work with LM 19.3

Hello altogether.
I recently got my hands on an Asus Taichi 21 Ultrabook (see here).
Naturally I installed GNU/Linux (Linux MInt 19.3 in this case).
Everything works fine out of the box, except the touchscreen part (outside lid).
If I close the lid, the “Windows-Logo” outside gets bright for some seconds, then out. Nothing else. Linux Mint falls asleep, as on a “normal” notebook.
When I open the lid again, Linux Mint wakes up just normal.
I started an internet search and found only a few hints that sadly do not deliver any solution:
Launchpad
Askubuntu

The second (touch) display is not recognized by LM at all:

There is a special key (the “Taichi-key”) on the keyboard, that switches from inner to outer display under Windows, but has no functionality when operated with GNU/Linux.

Surprisingly I can move the mouse on the inner display when touching the outer display…
Strange. There is just no graphics, but the “touchy” part is functional.

Inxi:
System: Host: TAICHI21 Kernel: 5.3.0-42-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8
Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: ASUSTeK product: TAICHI21 v: 1.0 serial:
Mobo: ASUSTeK model: TAICHI21 v: 1.0 serial: BIOS: American Megatrends v: TAICHI21.211 date: 04/21/2014
Battery: ID-1: BAT0 charge: 9.6 Wh condition: 36.5/37.6 Wh (97%) model: ASUSTeK TJ21-32 status: Discharging
CPU: Topology: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13569
Speed: 798 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.2.8 direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1b.0
Sound Server: ALSA v: k5.3.0-42-generic
Network: Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0
IF: wlp2s0 state: up mac:
Drives: Local Storage: total: 119.24 GiB used: 8.41 GiB (7.0%)
ID-1: /dev/sda vendor: SanDisk model: SD5SE2128G1002E size: 119.24 GiB
Partition: ID-1: / size: 116.87 GiB used: 8.41 GiB (7.2%) fs: ext4 dev: /dev/sda1
Sensors: System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2700
Info: Processes: 205 Uptime: 1m Memory: 3.73 GiB used: 612.4 MiB (16.0%) Init: systemd runlevel: 5 Compilers: gcc: 7.5.0
Shell: bash v: 4.4.20 inxi: 3.0.32

dmesg:

dmesg err:
[Mär28 18:55] ACPI Error: Needed type [Reference], found [Integer] 00000000c3461bc3 (20190703/exresop-69)
[ +0,000008] ACPI Error: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20190703/dswexec-427)
[ +0,000020] ACPI Error: Aborting method _PR.CPU0._PDC due to previous error (AE_AML_OPERAND_TYPE) (20190703/psparse-531)
[ +6,635556] Bluetooth: hci0: unexpected event for opcode 0x0000

I checked the BIOS version too, it’s the latest for this model (211)
I also tried with Ubuntu 19.10, just the same.
Downloading Arch 2020.03 at the moment, to try with that, because one mentioned, that ist would work with that.
[Update] With Arch there is no touchscreen available, also…

Maybe someone has a hint to solve this.
Thanks, guys and greetings from germany. Stay healthy!

1 Like

Hello Fast.Edi.

In reality you have a dual screen gadget.
It seems that Mint is not detecting the outer display.
You see, display and touch are different components (in a separate screen, or in a tablet).
So, what happens is that Mint knows the existence of the outer touch but not the screen.
Since there’s only one screen (the inner one), the outer touch is used on it.

I don’t know if there’s any Linux prepared for such an environment.
It’s my common practice to always test the hardware with Live pens on the first approach.
Here’s what I suggest: Try several Live distros of Linux on your Laptop/Tablet.
https://distrowatch.com/
If you find one that makes it all work, good. Otherwise you may have to stick to MSW for the whole working package.

My laptop has one screen with touch abilities. It gets recognized and you cannot turn it off with software, only with the special hardware key. The touchability is always on and always works with the Debian 11 that is installed on it. It actually is one of the most reliable things to work with Linux. It always worked.

Though, in my case, I think it is not recognized as a separate “screen”. I just have a single screen with touch abilities and that’s how Linux recognizes, it too. The Taichi21 is probably different.

Thanks for the replies…

I investigated a bit further on this case and found some windows related topics. They all state, that this “one lid with dual functionality” only functions with Windows 8, not with Win 10. So it seems, that even Asus has “abandoned” this model for newer versions of Windows.
Maybe I have to go with the 50% solution here, for the Taichi21 is (in terms of IT) quite old and maybe will never be supported fully by GNU/Linux.

Yes, I think so. The lid has practically 2 “monitors” in it, LM recognizes the whole thing as one monitor, but not as a divided device. Therefor it recognizes the “touchy” part as part of the inner display…

Maybe you are lucky and are able to find some very small project on Github, where someone had the same problem as you and wrote a driver or something. Sometimes it happens for very niché devices.

Maybe you could ask around in fora and see if someone finds something.

I realize this is a year old, however I was wondering if anyone has found a solution for getting the back panel to work with Linux?

Also, I just thought I would mention just incase someone didn’t know, the back panel and all original features do work in windows 10 now.

Hey.
No, unfortunately I got not any further with this issue…
(not giving up, though)

Aaaand, needless to say, Win10 is not an option… :wink: