Can't seem to boot from usb Flash drive

Hello, need help

I have an old computer with Pentium 4 32 bit. On it I have windows XP Pro along side Lubuntu 18.04 LTS. I would like to boot some Linux ISO distros stored on a Multiboot YUMI. On my BIOS F12 I do not see my USB despite the fact USB boot is enabled. When the computer is booted GRUB2 is displayed first in order for me to choose which OS I would like to use. Is there any way to get my USB displayed on my BIOS F12 in order to boot my Linux Distros.


have you tried creating the usb more than once in case the first write just wasn’t good? if that doesn’t work, there is a program called ventoy that also makes multiboot usb’s. maybe trying a different program will give a different result.

are you sure the usb is good? if you have another one to try, that might be another option.

1 Like


Thank you for replying so soon. The USB flash drive is fine I tried it on my laptop which is exclusively a Linux laptop not partioned with any Windows OS. The problem that I am encountering is on my desktop bios.
The USB does not show up when it comes for me to boot the USB drive from it when the computer is booted and F12 is pressed despite the fact it mentions USB boot enabled. By the way I also have Ventoy with several Linux ISO,s which was very difficult to create via a Linux terminal. I will give it a try on my desktop. I believe it is more of a BIOS issue I do not understand as to why it is not showing up in my boot priority. For some reason I plugged in an external floppy disk drive and it showed up. I had installed PLOP boot manager on it in order to boot my USB flash drive from it but it is not running. Any insights or suggestions will be greatly appreciated.


i have read that there are some older systems that won’t boot from a usb and need to have cd’s to run linux live. i would think a p4 system with xp on it would be young (relatively) enough to work. have you successfully booted a live usb on this system before?

it might help to know some of the system specs. if you could post the output you get from the command:
inxi -Fxz
that might give us some clues.

1 Like

If you haven’t already tried this, I recall that the USB flash drive has to be formatted in FAT 16 for some older BIOSes to recognise it.

1 Like


Everything seems to be fine after tinkering with the BIOS. I was able to boot my flash drive. First, Install flash in the hub, Boot the computer Press f2 to initiate BIOS when booting slide to BOOT tab go down to Hard Drive there my flash appeared change the boot priority reboot computer press f10 and click flash drive and the computer will boot to flash drive. et voila. It seems that I was looking in the wrong place (generic flash drive, generic drive, etc.

Once again thank you for your help. I will keep this correspondence if any other issues arise.

1 Like