Can't upgrade xps 13 to ubuntu 22.04

A couple days ago I upgraded my Inspiron to Ubuntu 22.04. There were a few minor issues after the upgrade: Couldn’t see videos, Virtual box wouldn’t work, and issues with sound. I solved them all. So I updated my xps 13 that came with Ubuntu preinstalled and tried to upgrade but can’t. I get the same error in the attached article. I’m left wondering if you bought a PC with Ubuntu preinstalled is upgrading off limits till some bugs are worked out? Why You Can't Upgrade to Ubuntu 21.04 (Update: Now Fixed) - OMG! Ubuntu!

Hi @Jamesread ,
There is another post on this issue.
@cliffsloane had the same video issues after upgrading to 22.04 and the problems seem insurmountable

What @Jamesread is stating, however, that update to 22.04 worked on one piece of hardware, but not another. I’ve done 20.04, then to 21.10, then to 22.04 on my RPi 4B (8 GB model) - hit a few snags, but worked through them successfully. I also did the 20.04 to 22.04 path on my Thinkpad E495 and didn’t hit any major snags (but that Thinkpad’s now running Fedora 36 [which itself was an inplace upgrade from Fedora 35]).


The key thing is, with you and @Jamesread , you have more than enough experience to fix things, and to know when to pull out.


You are correct my friend. The attached article is about 21.10 but made the point that Ubuntu wasn’t allowing people to upgrade for awhile because they realized there were some bugs. I’ve updated before trying to upgrade so I should be able to upgrade the machine. The only conclusion I can come up with is they aren’t allowing those to upgrade who paid $2,000 for a computer with Ubuntu preinstalled due to some bugs needing to be worked out? They didn’t seem to be open about the issue with 21.10 till after the fact. If this is the case I just wish they’d be more forthcoming about it and let the user make the choice. Give a warning: “if you upgrade now you may have some problems so beware.”


I think the thing hindering me from the upgrade is a Dell service update. I’ve found there’s a Dell BIOS upgrade that need to be done. I downloaded that and tried to put it on a thumb drive but need to do some research. I haven’t done any BIOS updates/upgrades. Anyway, I found this in the terminal----what update is hindering me from upgrading. A friend of mine who works in IT has a saying: “With Dell, you’re always one keystroke away from hell!” Maybe he’s right? lmao

Take care. I have not done a BIOS upgrade, but I have read that it is possible for things to go wrong and for the computer to suffer damage

1 Like

The probability is super low, though. The process usually takes like 1 or 2 minutes and the worst thing one can do is pulling the plug during the upgrade. Then things can go wrong. However, if you can spare the power to the computer for these 2 minutes, nothing should go wrong and never heard of anything going wrong, without pulling the plug.


Tonight I put the BIOS update on a flash drive rebooted and hit F-12 to enter the BIOS. Selected the BIOS flash update section but got this error: Either Enable WLAN in BIOS Setup options or Use Wired/Internet Interface Then restart to resume the operation. Checked and found WLAN enabled and found out of Dell support forums that this is a very common issue that doesn’t seem to have a resolution… I won’t blow my top yet. I’ll play around and do some more research this weekend. This seems to be the only thing holding me back from updating to Ubuntu 22.04. On the bright side, I’m single again so this will help kill some time and pain! :grin: :laughing:

1 Like

Took me about 20 minutes to UEFI update my desktop machine… But super low risk… Risk factor for bricking is usually when people do stuff like overclocking and try alternate BIOS/UEFI not released by the vendor…

Note also - NEARLY all modern desktop motherboards have some kinda “dual BIOS / UEFI” whatsit to further reduce the risk of bricking your motherboard…

I’ve never updated the BIOS / UEFI on a Dell laptop (or any laptop, for that mattter)…

Only updated my desktop mobo UEFI / BIOS 'cause I was having USB 3 issues, and looked my mobo details up and saw there were USB fixes in the latest BIOS…


What do you make of this? $ sudo apt-get upgrade -y
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

The “The following packages have been kept back:
dell-linux-assistant” What does that actually mean? If I go to the Dell-linux assiatant that’s where I find there’s an available BIOS update. Thanks for any input.

This may happen for a variety of reasons. For example, it is kept on the same version by the user, by using something like apt-mark.

However, it may also be related to some dependencies, which are not on a version, which is compatible with a newer version of the package that is being kept back, I think.

Not too sure about that, but this is what I remember.

Maybe the following links will help more.

1 Like