Casual thought about Chromium based browsers

Just a casual observation - maybe 12-18 months ago - and maybe the last 10 years…

I usually do some housekeeping on the number of browser tabs I keep open, Chromium, Google Chrome, Brave, MS Edge (not really Firefox - it’s always been pretty lean and efficient) : because I’ve experienced situations where some errant browser tab, can crash the whole browser,s sometimes even the O/S (more so on Linux or Windows, than e.g. MacOS) forcing a “last resort” power cycle…

I barely use Windows these days - have none at home, but - I usually have about 20+ browser tabs going at any one time (mostly in Brave) - and never had to crash (pkill brave or “kill -9 $(ps -ef |grep brave | awk ‘{print $2}’)”) in the last 12 months or so…

Have things gotten better?

1 Like

Im using Vivaldi for over a year. I have at the moment three windows open. Window 1 has 4 workspaces. Workspace 1 has 21 tabs. Workspace 2 has 8 tabs. The other workspaces are empty. Window 2 has 80 tabs open. Window 3 has 3 tabs open. The single largest drag on the browser as a whole is facebook. Once to three times an hour that single tab revs up the cpu, drags down the memory… all for about 5 to 8 seconds and then back to normal. Ive never had the browser crash when fb has been closed. I did have some problems early on but it was specific to updates Vivaldi did on top of Chromium. Other than that - I would def say things have gotten better. I leave my browser routinely running with tabs I cant close for work reasons for many days without issue.

I still use firefox but I cant keep anywhere near the number of tabs open in that. However, my work right now is a bit unusual and normally wouldnt keep this many open.

1 Like

Arise DEAD THREAD! Arise!

I’ve noticed something that happens in Brave, but not Google Chrome - if I change my network settings - e.g. disable ethernet and use WiFi only (or vice versa) - Brave shits itself, but Google Chrome still keeps working.

I have to exit Brave, then re-open it - to make sure it works… every single tab I normally open, stops working if I cutover to e.g. WiFi to my phone’s 3/4G if my Broadband becomes dodgy (which is has been the last 4 days!).**

But Google chrome happily trundles along… Brave must be doing something internally (its own DNS cache maybe?) - and I don’t like that - but it won’t stop me using Brave - 'cause I CANNOT STAND ads in Youtube!

** had an NBN tech visit this morning, dispatched by my ISP, he reckoned it should be good but was suprised how long long my router takes to connect… 5 minutes after he scarpered - it still hadn’t connected - 55 minutes AFTER he’d scarpered, STILL no connection.

I dug out my old router from my ISP and that didn’t connect either!

Plugged the “new” one in again - and fiddled with this and that - and it eventually connected - at 1 mbit! (I’m paying for 50, but lucky to get 33). But what was the point of the NBN dickhead visiting - he obviously DID NOT FIX something that’s obviously BROKEN since about 1:45 am on Monday morning!

Ask for one of the new modems that automatically drop back to a mobile connection if the internet link fails. At least you would get about 20Mb via the mobile link, while they pass the buck on fixing the line.

1 Like

I got fed up of waiting.

Emailed my ISP support about midday Friday and advised if it wasn’t fixed by the end of the week (COB Friday) I was going to escalate the issue to the Telecommunications Ombudsman.

By about 11:00 am had not had a response from NBN or my ISP, so I raised/reported an issue with the Telecommunications Ombudsman.

Then I actually got a call from my ISP telling they were working on it and escalating to NBN - but I’d already logged the case with the Ombudsman.

Was consistently sitting on between 5-7 mbit/s all Friday afternoon and into the evening, and disconnecting randomly.

Get up this morning, look at my speedtest-cli logs (I have a cronjob on my Pi4 that was running speedtest-cli every hour at 45" past the hour, I increased that to every 5 minutes) and WOW!

It’s hovering 38/40 mbps! This is the FASTEST my link has EVER performed… This happened around 1:00 am Saturday/today (and interestingly the issue first happened around 1-2 am on Monday).

Approx 39 mbps download and 9 mbps upload. That’s “acceptable” - but I wanna know why it’s taken 5+ years of complaints about not getting what I’m paying for (best I’d ever get previously was 33, and usually sat on about ~28).

But if this is solid and reliable and stable, I’ll happily accept it.

Back to work on Monday (work from home) - thankfully I now seem to have stable internet connection (touch wood and fingers crossed!).

1 Like

Thats about what we get with fixed wireless when it is busy.
In slack periods it goes over 50 Mbps download.
We share the tower with I dont know how many neighbours.

You might still look into the new modem with auromatic mobile backup.

No - they’re not “free” from my ISP… and just recently replaced the 5+ year old Netcomm my ISP supplied, with a TP-Link VR2100… Mostly 'cause the WiFi on the Netcomm device was pretty woeful… The Netcomm had a default setting of max 16 devices on each AP (i.e. 2.4 and 5 Ghz APs) - was able to bump that up to 32 each - hit that ceiling (16 devices) during my initial WFH when Covid first hit in 2020…

But the TP-Link WiFi is heaps better - and the “single” AP feature (where 2.4 and 5 ghz APs are presented as a single AP) seems to work just fine…

And my current ISP does not have 5G internet plans, period, so no possibility of 5G “backup” or “failover” anyway…

Yeah, my backup is 4G. No Telstra 5G in our region.
Telstra modems are supplied free… if you have a contract.
I have no Wifi issues with the Telstra modem. Not sure how many Wifi conndctions it supports… we have 7 going.

I’ve had pretty good luck with my TP-Link devices.

I’m not sure if we’re all using the same units and measurements, but here’s what I see after running a speed test on my Xfinity ISP.


Had to jiggle my power connections in the kitchen (my ethernet over power wasn’t working) - so had to move the TP-Link to another power outlet - now - it won’t connect - it’s taking for ever, “Please check if your phone cable is properly connected.”

Yeah - bullshit - tried another phone cable too - same issue.

I’m once again - tethered to my phone’s 3/4G… this is getting ridiculous.

I will need my broadband when I go back to work tomorrow!

This is what I was getting a few hours earlier :

That’s the best I’ve ever gotten out of Abbott / Turnbull’s sabotaged NBN with hybrid Fibre-2-the-Node (it was supposed to be fibre to the premises when launched by the previous government)…

What I’m getting now is a big fat ZERO!

Update - after 30-40 minutes it eventually connected - and now it’s the FASTEST I’ve ever seen it run for speedtest (on MacOS) :

Router page :

My Telstra fixed wireless speed test 20.42 EST

You are doing OK if you can maintain that last figure.

Not everyone has multiple options or even one good option for internet access. I’ve recently gotten a second option of fiber to the door and took it. The bonus part is it’s the same ISP we use at work and they’re in the same building we are. My ping from home to work has a 2 ms response time and I have a 1 Gbps down and up connection. When I work from home over VPN it really is like being there. I normally see something near 900 Mbps using my work laptop on CAT5. Over WiFi it varies a bit depending on the device and where I am in the house.

That is 10x faster than the best option in Australia.

No - there are 1 gigabit internet plans for certain neighbourhoods…

I just happen to live in a digital slum, and regional locations are considered the digital boondocks… There really is a digital divide in this Country - affluent suburbs are vastly more likely to have cable and / or fibre. My brother lives in a “leafy” bayside suburb of Melbourne, and he has fibre.

There’s a suburb north of me - i.e. further away from the city than I am, that’s getting a complete fibre roll out to every street… But not me or my suburb!

Note : sometime after midnight (this F–KING thing always seems to F–KUP in the wee hours!) my link dropped down to sub 20 mbps, mostly ~10 mbps… it fluctuates…

It’s not good enough.