Chromebook and the linux struggle

Okay so here it goes… I have followed the directions and at first I gave up because everytime I typed in start my screen would become pixelated and froze (however it’s frozen like that on full screening a game I play. I found out after redoing EVERYTHING that if I closed my chromebook and opened it back up that it fixed itself!.. But here’s my new problem I can’t click anything on the linux screen. I did notice though if I switched back to chrome os then back to linux that it recognized my previous clicks… I can’t do anything like that, have you or anyone encountered something simular? did I do something wrong do I need to turn something off or on?

Could you elaborate on what exactly you did? Step by step, precisely. Thanks.

Sure thing, I guess I was pretty vague, but wasn’t sure of replies… Anyways, so I started off following the instructions from this website. I switched it to developers mode. Then I installed it (xfce) version, everything worked fine at this point. I created a username and pswrd in shell. I typed “sudo startxfce4” to get it to start up, that’s when it crashed. Well kind of; the screen froze and was just colors, lines, pixels, etc. Out of frustration I closed my chromebook, I opened it back up shortly and there it was I was on the linux home screen. At the beginning I could only move my mouse in a small box on the center of the screen I switched back and forth and was able to move the mouse all over. However nothing would open or anything I switched back and forth again and the internet was open twice (I clicked it twice before switching over) but still things only seem to open if I switch back and forth but not really

Yea okay so as of right now when I press ctrl alt shift back or forward when I go to the linux home screen and click something no matter how much time in between it only opens up if I switch again

Would be appreciated if you could expand the it to something useful, so we can comprehend what you are trying to say.

You should not interrupt and installation this way, especially if you don’t know what you are doing. Best thing right now would be probably to purge the old installation and install it step by step, as in the tutorial, again, but without doing anything out of frustration.

I think you’re misreading my terrible explanation, but you’re right about me not completely knowing what I’m doing. Everything was done to a T in these instructions and multiple times because I thought I was wrong at first… It’s completely installed and I didn’t do anything whilst this was going on. My screen freezes everytime I start it up though. That is why I closed the book. However when I opened it back up to just restart and say screw it… That’s when I noticed that it wasn’t glitchy anymore… so when everything was frozen yet again I switched back to OS and When I thought I gave it time to rest or whatever I just tried to switch back just to see… and those apps/files I clicked were now open… I thought it was a time thing… like maybe my book is slow, so I clicked to close those apps/files but nothing happened… I waited and still nothing… This leaves me to now where I went to reach out from the guy who wrote the instructions and realised this is a forum site and I posted here… bottom line is nothing happens on the linux homescreen while I’m on it I literally followed the directions and copied and pasted the commands… I thought maybe it was just my chromebook so I wanted to see if anyone else experienced something simular

How about you paste your entire system info here, like your Chromebook model etc. and make a numbered step by step explanation on what command you actually executed, how and where, when. Be precise. It is hard to understand what you are trying to transmit.

do you use facebook or whatsapp? I mean I can show you… all I did was

Step 1:

Go to the Github directory of crouton. You should see a link to a script on this page. Download it.

It will be saved in the Downloads directory, exactly where we want it to be.

Step 2:

If you did not know already, there is a terminal in Chrome OS, crosh (an acronym for Chrome Shell). This is not a stand alone GUI program, it is run inside Chrome browser.

If you press Ctrl+Alt+T (yes, the same shortcut as in Ubuntu), the crosh terminal will be opened in a new tab in the Chrome web browser.

Type the following command in it:

shell

By default, crosh doesn’t support all the Linux commands, not even cd or ls. But when you use shell, you can use the normal commands like ls and cd, and run shell scripts.

Step 3:

So, we have the crouton script already saved in the Downloads directory. All you need to do is run the following command:

sudo sh ~/Downloads/crouton -t xfce

Instead of xfce, if you can use:

  • kde to install Ubuntu with KDE
  • unity to install Ubuntu with Unity
  • touch,kde to install Ubuntu with KDE for touchscreen Chromebooks
  • touch,xfce to install Ubuntu with XFCE for touchscreen Chromebooks
  • touch,unity to install Ubutnu with Unity for touchscreen Chromebooks

You can also use the parameter e for encryption. Then the command will become:

sudo sh -e ~/Downloads/crouton -t xfce

I usually do not favor encryption for regular users, but the choice is yours.

If you ask for my advice as to which desktop environment should you choose among Unity, XFCE, and KDE, I’d advise XFCE because it takes fewer resources. Surely, a [lightweight Linux distribution]

Step 4:

Once you have entered the command to install Ubuntu, you need to wait. The installation takes time because it requires downloading the entire operating system. The installation time depends on your internet speed. For me, on a 50 Mbps connection, it took around 15 minutes.

The good thing is that you can continue doing your work on the Chromebook. The installation will not obstruct normal computing.

Just keep an eye on the installation, because at the end you will be asked to provide a username and password.

Ubuntu installation in Chromebook

Also note the command that you need to use for starting Ubuntu. As you can see in the screenshot, for Ubuntu XFCE, you’ll use the command startxfce4 .

Step 5:

When the installation is finished, you can start Ubuntu by using the command below:

sudo startxfce4

When I type this in “sudo startxfce4” my screen crashes… I actually took some pictures to ask a buddy but he didn’t know anything about chrome…
in these instructions it says you can switch by ctrl alt shift forward or backward on the top row. and I’m able to do that but I cant interact on the linux version… however if I click something on the linux version it opens as I switch back I just cant interact at all when I’m on it

I don’t know anything about Chromebooks but found this on the web;