Chromium asking for password


#1

Hi there, I’ve installed linux lite on an old 32 bit pc and it works fine. But every time I open chromium it asks for a password about 4 times and that’s quite annoying. I don’t want to log into my chrome account. Is there a chance to get rid of this issue?
Thanks for any help, I surfed the internet but couldn’t find an easy (not using terminal) answer

Andy


#2

The probably not so expected response from your view would be, that often many things are easier using the terminal. It’s especially like that when you get used to it. I use Linux in different ways daily (90% command line only) and can tell you that you feel weaker and more powerless with every time that you see what you can do with a terminal very directly, quickly and comparatively easy while there are so many things that are very cumbersome when done through the GUI or (which is the worst possible option and yet happening way too often) you can’t do it in the first place, because the GUI doesn’t offer such option. Therefore I would advise you to use the CLI at least this time to solve your problem easily.

To make a deal with you, I suggest you post the “terminal way” of doing it and if you don’t understand something, we can ease it up for you so it won’t fail on your terminal which would probably be annoying.


#3

I’ve run into this many times on fresh installs of Ubuntu-based distros when starting chrome/chromium. The simple solution I found is to go into the “passwords and keys” settings of the OS and set the password to nothing (leave it blank). Note; this doesn’t change your login or admin (sudo) password, this is for a different purpose. Once you do that, it shouldn’t popup or ask you again.

Alternatively, you can also try just entering a blank username and password and that may work.


#4

Bizarre as it may seem it’s quite normal the requests
Answer
Just ignore them and wait they disappear after a few mins then take you to the real log in screen unless you said no password …

Caught me out first time
Then second time was busy on other things so forgot and eventually it went in to main screen


#5

I have the same issue and indeed this is annoying. Apparently this is related to Chromium trying to open the keyring (where site passwords are stored).

Until now, I left this as it is currently. And I try to live with that annoying dialog, because all other “simple” solutions (blank password, or using --password-store=basic) makes it disappear, but at the cost of strongly weakening the security (of all gnome-keyring clients in the case of the blank password, or by storing passwords in clear text in the case of the basic store).

I didn’t give a try to installing libpam-gnome-keyring, but I suspect this is the right answer to the problem.


#6

Are you using automatic login? If yes, then it’s a security feature. Your browser saves passwords for various website logins. In case of automatic login, anyone can use the browser and will be able to login to the websites you have saved password with.

This is why you need to unlock the keyring with your account password so that only an authorized user access the website logins with saved password.


#7

Yes I use automatic login as it is my home PC, but I have another PC in my office with Mint and it doesn’t ask for the password at all. It’s a much newer PC but I don’t think that’s the cause.
But incredibly, today it hasn’t been asking for it, I got a few updates, could it be that simple?


#8

I am not sure but it could be a ‘feature’ enabled from the distribution itself and perhaps Mint doesn’t do it.


#9

I have had a similar niggle and this is absolutely the answer. Thank you!


#10

You’re welcome :slight_smile:


#11

If you do not have to sign in Chrome, Chromium and Opera in my experience ask for a login or keyring to unlock them. Since I started to need a sign in, I’ve not had that problem with any browser.


#12

You can ignore the password, not put anything.
With the time, no longer appear.Or you can use
FF Quantum, very fast and useful ( no annoying passwords asks :wink: )