Command "Urgently" Needed

I have 3 flash drives, and 7 SDHC chips that somehow got locked into “Read Only”.
Also, a few of these are not recognized when I insert them into usb slots.
I have tried many, many, different things, including gparted, several different DD
commands, yet nothing has worked. I’d very much appreciate any, and all help on this
very perplexing(to me), problem. Thank you.

I’ve run into this now and then, a real pain. I think it comes from a drive having been removed from a Windows machine without being properly ejected. Some bit gets set that should be un-set before unmounting. This prevents normal behavior of the chip. Try plugging them into a Windows machine, sometimes that allows them to be read.

Or, if you don’t need the data on them, reformat them with gparted. (gparted sometimes “sees” the drive but won’t mount it. But it has let me reformat it.)


Another possibility: I have read that when a USB stick changes itself to read-only it is indicative of a hardware failure. The advice was to get the data off the drive and discard the failed (i.e., read-only) one.


Thank you both for your replies. It positively is not a hardware problem, and gparted does not even see any of these. I’ve even tried using different usb slots, still nothing.

Would you be able to try these usb devices in another computer?
If gparted and your OS both can not detect them, the problem
is most likely your computer usb hardware or the devices .

1 Like

Thanks for the reply.