Computer Building SNAFU - DRAM error, no video output

Hello. I am building a new computer and I’ve hit a very frustrating problem.

I’m using the following in this build:

mobo: ASUS Prime X-570-Pro
CPU: AMD Ryzen 5 5600x
GPU: Nvidia GeForce RTX 3060
RAM: Corsair Vengeance RGB Pro DDR4 3600MHz 2x8GB
Storage: Corsair MP-600 m.2 ssd 1TB
PSU: Corsair HX1200

Problem: the amber DRAM led on mobo is illuminated indicating a RAM problem and NO video output.

 1.  the RAM I have now was not what I used initially.  Initially I used G.Skill last was listed as compatible with this mobo on G.Skill's website, but it wasn't listed/tested on ASUS's website.
 2.  I sent the RAM back and ordered the above RAM which is listed on ASUS's website  
 3.  That failed to correct the issue.  After talking to ASUS tech support they suggested I may have a bad mobo.  So I exchanged it for another.   The same problem is exists with the new mobo.
 4.   Some Forums have referenced resetting BIOS, but I can't do anything with BIOS because I can't see any menu options because there is no video output.

Did I wire something up wrong? I’m baffled. I thought I would check here before taking into the local computer store.

Thank you for any and all help.

I ran into something very similar earlier this year, an MSI X-570-A Pro chipset motherboard… Ryzen 7 3700X…

4 x 4 GB @ 2133

I bought these in 2016, by mistake, had nowhere to use them… nothing with full size DDR4 slots…

So I got the Mobo and CPU and M2 SSD, and tried booting / POST with my 4 x DDR4 RAM… Got POST errors and light DRAM error lit up on the Mobo… Gave up… ordered a pair of 16 GB DDR4… But - that was gonna take a while…

Few days later, I thought, maybe I’ll try one DIMM at a time, and sure enough, it worked, so I tried two, and that worked!!!

So - I booted up and installed Ubuntu 18.04, upgraded to 20.04 - went swimmingly… Then I was still waiting for that RAM, so I thought, maybe I didn’t seat them properly, so I tried ALL 4 of those 4 GB DIMMs and it successfully POST’d and successfully booted!

So - I put it down to me not seating one of those modules correctly…

But - if that’s not your probably then, maybe go through my trouble shooting process? Try POST with each bank, one at time, that should show up if one of them is bad… you can run with an odd number for a while, it will “break” dual channel, but that’s nothing major, till you replace the dodgy module?

So - anyway - I have 40 GB RAM, i.e. 2 x 16 GB + 2 x 4 GB, they’re all running at 2133, I can’t remember what spec the 16’s were when I bought them, but I suspect theyre 2666 or slightly higher, but crippled down to 2133 to maintain stability with the 2133 pair of 4GB modules…

It sounds like you’ve done this multiple times already, so I doubt it’s a seating issue, but you may care to try one module at a time?