Corrupt HDD. Cannot retrieve data


#1

I have 4 external 1TB HDD’s, and one of them cannot now open, in as much as it will not mount. Is it possible to retrieve data from an HDD disk? It has my family tree, and 100;s of photographs on. Any ideas on how I can retrieve this data will be greatly appreciated.
Many thanks


#2

Ouch.
Here’s some ideas to try first of all other attempts:

  • Try attaching it to another USB port of the machine
  • Change the USB cable of the harddrive
  • Try to attach the harddrive to another machine, maybe with another OS (Windows)

If the harddisk is not responding in any way on the operating system (try lsusb or PartetMagic to verify) one must think of other possibilities to get to the data…


#3

Does your external drives have their own power or just USB linked, such as my 2.5" case with 500Gb HDD and USB only connector, for mobile use when out about.

With my iDsonic docking station, I have been able to read some ropy HDD in my time. Essentially plug it into the bay and use it like you would a USB stick.

:sunglasses:


#4

Good point, do you have a “Y-cable” with 2 connectors on the pc-side?
If so, try connecting to both of them. Maybe a power issue (?)


#5

Is is formatted for windows as many are - if you so then, if you have access to a windows OS then you can plug in you hdd and when it shows in my computer as a drive, then right click and run the repair tool. Once this has been done safely remove it and then reboot and it should be okay. Then try in whatever you are using in Linux and it should work for you. I have done this in the past with a WD external drive and it worked.


#6

Seems like I’m a bit late here, but I can confirm all the help the others have given so far. Try out those things step by step. :+1:
If you will still face problems, then tell us. If you will have solved the problem, you should tell us what solved it, as well.


#7

Thank you to those who replied with possible answers to my problem. Thank you to ElectricDandySlider, Edgar Hoffnan, and Akito. However, I have only Linux mint 19.0 OS, and no Window buts I will continue with my efforts, because the data is very important to me.

Goodmans


#8

If I were you I would be very careful. If you really want to retrieve the data you shouldn’t do anything with the disk, especially no write operations. You should take a look at testdisk and photorec. These are the best programs for recovering data. testdisk is for recovering system partitions etc. whereas photorec is for recovering documents, photos, videos, etc.

If I had your HDD it would be probably easy for me to recover the data, but on the other hand it is hard to explain to you how exactly to do it in your specific case. Well, if the data is like super mega important to you, then you should really sit down and read the documentation and tutorials for these tools for a couple of hours and then you will be able to recover the data yourself, I am sure. If you will take this path, here are some more helpful tools:

https://clonezilla.org/

https://www.sleuthkit.org/

https://www.caine-live.net/

I use these and a couple of lesser tools for when I recover data from HDDs. It’s not easy to get into it, but if you really really need the files and don’t want to pay thousands of $$$ for some foreigners to do that job, you should do it.


#9

Just to let everybody know that I have taken your good counsel, and have recovered 15000 odd files at the moment, using TechMint “PhotoRec – Recover Deleted or Lost Files in Linuxt”, with quite a few hours to go, until recovery is comlete. When it has been done, then I have to find out how to get them to a windows file that I can read.
Many thanks to all
Goodmans


#10

This is because of how the file system works. It’s actually quite human-like. Do you remember that fat kid from high school that always slipped on a banana? So you remember him but not his name? Same with the recovered data. It looks for data on the disk and recovers what it finds there by size, etc. but it doesn’t necessarily find the names previously given to it.

They can already be read, but you potentially have to rename them or allow a program to open weirdly named files.


#11

Any updates?

Summary

Any updates?


#12

95% recovered. In home directory, then when recovered all, reformatted HDD to NTFS, and put them back. All seems to fine, fingers crossed. Many thanks to all for the assistance.


#13

glad to hear you are getting your files back :slight_smile:


#14

Tanks. Took me most of yesterday and this morning, but EUREKA, I do believe it worked.


#15

since you have a few different external drives, it might be a good idea to have at least a couple copies of anything you feel is truly of value. i don’t bother with a lot of my stuff, but make sure at least my family photos are duplicated just in case.


#16

The drive that went down was my 1TB of all back ups. I don’t know why it failed though. However, I have used Partition Magic, created a new partition, and cleared everything out. Seems fine now, and I’ll start using it again.