CUPS not working in Linuxmint Mate 20

I have just installed LinuxMint Mate 20 and cannot get it to recognize my network attached printer. The printer was working perfectly until I changed the OS from LinuxMint 19.3, Tricia.

I have removed CUPS and reinstalled CUPS using Synaptic, but the same problem persists.

Does anyone know how to fix this. I’ve done all I know to do and am stumped!

Thanks to all!

What have you done already?


printer make and model as well as computer make and model may be helpful at some point also.


The printer is a Brother HL-5450DN and the computer is an AMD RYZEN 7 - 2700x build with Radeon FX-560 video and 16GB RAM.

The printer is long serving and has always worked. It worked yesterday before I installed LM Mate 20.

Are there any know issues with CUPS as provided by Ulyana?

I have removed CUPS and reinstalled CUPS using Synaptic, but the same problem persists.

can you run lpinfo -v in a terminal?


~$ lpinfo -v
file cups-brf:/
network beh
serial serial:/dev/ttyS0?baud=115200
network ipps
network lpd
network socket
network ipp
network https
network http
network smb
network dnssd://Brother%20HL-5450DN%20series._ipp._tcp.local/


ok. so it looks like cups sees and identifies your printer correctly. i haven’t used mint mate much. do you have a printer dialog that looks something like this:


1 Like

I get something similar, but the CUPS say it cannot find the printer which I can ping on my local network.

it doesn’t show up in that window or it won’t let you add the printer? where does cups say it cannot find the printer?

1 Like

When I try to send a job to the printer CUPS indicates that it cannot find the printer. It in the printer queue GUI.

what are you using to send a job to the printer? office writer or something similar? that printer applet?

1 Like

I have been using LibreOffice.

does your printer show up in that applet/program pictured above?

1 Like

It shows up, but CUPS complains that it cannot communicate with it.

that is what i want to check on by right-clicking on the printer and choosing properties from the menu that pops up. can you screenshot the properties and post it so we can look through them?


Thank you, all. I have reinstalled 19.3 and will wait for 20 to catch-up. This is very disappointing. One of the primary criteria I have with linux is that a distro must establish a network connection and have the ability to connect to available samba servers and CUPS devices with little or no action on my part. Communication is the name of the game.

As things stand right now, Mint 20 only meets the requirement for a network connection. It refuses the work via samba and CUPS is a total loss.

This issue can go away now. Again, my thanks and best wishes!

1 Like

thanks for letting us know you found a solution even if it wasn’t the one you were hoping for. i’m glad to hear you got your printer back to a working state, but sorry to hear that meant you had to revert.

if you are interested in future-proofing yourself against cups losing communication with your printer again, it might be helpful (for you or anyone else who might read this with similar frustrations) to take a look at the properties listed in the printer applet when the printer is functioning correctly and note your uri as well as what is in the make and model field. doing so to me feels like making a backup of config/system files just in case (an ounce of prevention…). mine looks like this:

the uri describes how cups will talk to your printer and where to send that communication. this can be changed with the button to the right (or lpadmin) if it isn’t working or somehow is affected by a system update/upgrade. the make and model field describes the driver or ppd cups will use to tailor that communication to your particular device. this can also be changed if need be.

all of that does depend on the printer using a protocol that is known to cups. of course if it worked before, that is pretty much a given. lpinfo -v should be able to confirm that.

i hope you understand that i’m not suggesting you should go back to mint 20 and try these options :slight_smile: i just wanted to leave a little hopefully helpful info at the end of the discussion in case it might be of use.

all of those settings are also available for viewing on my ubuntu 18.04-based (bodhi 5.1.0) system in /etc/cups/printers.conf. because of permissions sudo should be needed to cat or otherwise read that file.