Deja Dup backup

I get the following display in my Daily Backup routine:
Could not back up the following files. Please make sure you are able to open them.
I am unable to open the above files as advised above, as they are “Locked”.
What am I supposed to do?

You should find out which program is actually using these files: check out the lsof command. However, can you not just continue your backup without these? The important stuff is the personal files, not the system.

Don’t worry about them. Found this on the web.
I created a list of this answer that contains some coments in this form:

#These directories may be excluded:

.gvfs                           # contains mounted file systems?
.Private                        # contains the actual encrypted home directory
.dbus                           # session-specific
.Trash                          # do I need to say more?
.cddb                           # cached info about audio CDs
.aptitude                       # cached packages lists


.adobe                          # Cache for flash, maybe others?
.macromedia   # except for Flash persistence, there is no reason to keep this


.xsession-errors            # contains errors from the current graphical session
.recently-used              # recently used files
1 Like

Mina, I am in fact continuing to backup without the two ‘locked’/inaccessible files. I was just curious to know the reason why the system was not able to back them up, and why it was throwing up the alert to check whether I could open them - whether not backing up the missing two files, would have any bearing on the outcome, when they are retrieved for re-installation was my only concern.
I ran the lsof command also - it generated such a long list of files that it took a while for me to go through; it was like searching for a needle in a haystack; neither was I able to decipher the content of the terminal output, nor could I trace the cited files or the programs which were using these files. Period.

@anman49 I don’t really know what these directories are for. Did you read the different options for lsof?
Might it not be possible that they become locked by the backup process itself?

Why don’t you try e.g. lsof -r +d /home/mina/.config/menus whilst doing your backup? The output’s first column should specify the command which has the file opened.

Thanks Mina. I tried the terminal command suggested by you and got the abridged versions of the contents of both the files, and the programs listed therein with their corresponding Directory names and Process ID’s (PID) etc. I have made a copy of the information generated by the system backup process for my record, but they seem to be of academic value - nothing much to worry about, I suppose.

1 Like